Wake On Lan (WOL) feature inside MediaPortal (1 Viewer)

edterbak

Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Netherlands Netherlands
    Country flag
    The default 10 sec were too small in your nas to wake on. Can you increase it?
    No, not enough.
    22-59-11.png WOL parameters.png

    Settings and result above.
    The time required is probably depending on my hardware.
    ASROCK B75 + i3.
    I notice a difference in startup time when there is a DVD in the tray or not. With dvd it takes about 5-10 seconds longer as the OS and bios needs to figure out what is on there.. I think.

    [edit]
    @regeszter
    Oh sorry. My anwser is confusing. No, it is too small by default. and YES I can increase it :) Sorry for the confusion.
     
    Last edited:

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    Hi,

    can you test with the attached files? Just replace the files.

    • Check if can you enabled wol in mapped drive.
    • Check if the mapped network drive allways offline or not on root view.
     

    Attachments

    edterbak

    Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Netherlands Netherlands
    Country flag
    Hi,

    Tried v8.1.zip.

    Here are the results.
    Case 1:
    When using normal server adress \\...\ all is normal and good.
    config_folder_2.png
    22-28-02.png

    Visible when entering MyVideo and shown as offline. WOL works as should

    Case 2:
    When using mapped networkdrive, cant select WOL.
    config_folder.png
    22-36-39.png

    Visible as ONLINE when entering MyVideos. WOL doesnt work (ofcourse) and shows an empty folder.
    22-36-54.png


    PS
    I still test using DW, because this skin shows me the folder online/offline status. Titan doesnt as far as I have seen it.
     
    Last edited:

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    All work as I expected. The user have to use UNC path if wants to use WOL. We need to put this info to the documentation.
     

    edterbak

    Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Netherlands Netherlands
    Country flag
    just one thing I noticed. When mapped network drive is offline, it shows as online. If this can be shown correct as well this is perfection. :)

    Great work regeszter! Thank you.
     

    regeszter

    Retired Team Member
  • Premium Supporter
  • October 29, 2005
    5,335
    4,954
    Hungary Hungary
    The mapped drive will be same as normal drive. If the user wants to handle it by wol "service" needs to use UNC path.
     

    edterbak

    Test Group
  • Team MediaPortal
  • March 4, 2008
    2,114
    1,176
    Netherlands Netherlands
    Country flag
    Ok, So I now understand the network folder mapped, is seen as a local folder. Not possible to detect it is actually a network folder.
     

    dvgeek

    Portal Pro
    November 16, 2013
    64
    38
    SF Bay Area, California
    United States of America United States of America
    @regeszter - Thank you so much for this! Running MePo1.6.08 with patch 8.1 - works great! Hope this makes it into 1.7 Final !!!

    No need for the WOL Plug-In anymore.

    Observations for thought -
    1. When the MePo client starts, it starts up all mapped network shares, even if I want to watch Live TV - by design? Shouldn't WOL start the network share server only when folder is selected in Videos / Music /etc.
    2. After initial start, lets the server go to sleep and then wakes it up when folders are selected from Videos / Music / etc. - works GREAT !!!
    Again thanks for a great feature!
     
    Last edited:

    azzuro

    Test Group
  • Team MediaPortal
  • May 10, 2007
    9,366
    4,994
    France - IDF
    France France
    Country flag
    No need for the WOL Plug-In anymore.
    only for internal Myvidéo, because plugins are not supproted yet . regeszter must work with plugin dev for that.

    When the MePo client starts, it starts up all mapped network shares, even I want to watch Live TV - by design? Shouldn't WOL start the network share server only when folder is selected in Videos / Music /etc.
    only when you enter in shared drive, wol packet must be send. maybe you use your nas for TV side ? or shared folder are checked as default when enter in plugins ( not tested this case )
     

    dvgeek

    Portal Pro
    November 16, 2013
    64
    38
    SF Bay Area, California
    United States of America United States of America
    @azzuro -

    My setup:
    Dedicated TV Server - MePo1.6.081 Srvr only install with Argus TV 2.2.1 scheduler (have not found a better scheduler yet) - RecordeDTV and TimeShifting on this
    Dedicated NAS for Videos, Music, etc.
    Dedicated MePo 1.6 client in living room with StreamedMP skin

    As I have to use Moving Pictures instead of MyFilms and Moving Pictures plug-in is configured to be InHome, instead of in InPlugIns, going by your second comment, I'm thinking StreamedMP/Moving Pictures send the WOL command, even if I'm starting the client to watch LiveTV only. Will try and test - have to be careful here not to upset WAF -:)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom