Win10 falls creators update problems watching videos | Page 14

Discussion in 'General Support' started by joker1639, October 15, 2017.

  1. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,228
    Likes Received:
    6,189
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,180 / 9
    Home Country:
    France France
    Show System Specs
    That's a good news :)
    This part of code will go in the next 1.19 Final :p


     
    • Thank You! Thank You! x 2
    • Like Like x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Chisum
    • Premium Supporter

    Chisum MP Donator

    Joined:
    December 14, 2013
    Messages:
    26
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +16 / 0
    Home Country:
    Germany Germany
    Can confirm startup with no black screen with v422. On startup you see MP-GUI, then for a short flicker the desktop, then again MP- GUI. Unfortunately the other blackscreen issue is unchanged. I have framerate 50p and DRR, if I play a video with 23 p, screen gets black, sound plays. I can refresh monitor by pressing volume up or down or Windows button or CTRL+Esc. If I stop video again, screen goes black again. Here logs
     

    Attached Files:

    • Thank You! Thank You! x 1
  4. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,228
    Likes Received:
    6,189
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,180 / 9
    Home Country:
    France France
    Show System Specs
    Hi @Chisum :)

    In your log we can see, the GPU is removed when DRR kick-in :
    Code (Text):
    1. [2018-01-07 14:11:35,843] [Log    ] [MPMain   ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Intel(R) HD Graphics 4600
    2. [2018-01-07 14:11:35,847] [Log    ] [MPMain   ] [INFO ] - Main: Video Device or Screen Intel(R) HD Graphics 4600 removed
    But come back only after the video stop :
    Code (Text):
    1. [2018-01-07 14:11:53,537] [Log    ] [MPMain   ] [DEBUG] - Main: WM_DEVICECHANGE (Event: DBT_DEVICEARRIVAL)
    2. [2018-01-07 14:11:53,541] [Log    ] [MPMain   ] [DEBUG] - Main: Device type is DBT_DEVTYP_DEVICEINTERFACE - Name: Intel(R) HD Graphics 4600
    3. [2018-01-07 14:11:53,545] [Log    ] [MPMain   ] [INFO ] - Main: Video Device or Screen Intel(R) HD Graphics 4600 connected
    4. [2018-01-07 14:11:53,549] [Log    ] [MPMain   ] [DEBUG] - GraphicContext: device video connected - Count 2
    And somehow, the workaround code to make display the MP GUI isn't trigger, so i need to think about it :p
     
    • Thank You! Thank You! x 1
  5. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,228
    Likes Received:
    6,189
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,180 / 9
    Home Country:
    France France
    Show System Specs
    Hey :)
    I'm uploading a V424 version in madVR thread, if you can give a try :p
     
  6. Chisum
    • Premium Supporter

    Chisum MP Donator

    Joined:
    December 14, 2013
    Messages:
    26
    Likes Received:
    4
    Gender:
    Male
    Ratings:
    +16 / 0
    Home Country:
    Germany Germany
    Tried v424 and looks good, DRR video and wakeup with no blackscreen. Hope logs will help. Thank you, Sebastii, for your patient work.
     

    Attached Files:

    • Thank You! Thank You! x 1
  7. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,228
    Likes Received:
    6,189
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,180 / 9
    Home Country:
    France France
    Show System Specs
    Thanks a really good news :)
     
  8. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    10,944
    Likes Received:
    4,711
    Ratings:
    +6,751 / 11
    Home Country:
    Germany Germany
    Show System Specs
    @Sebastiii what exactly caused the black screen, a "device lost"? Could you point me to the related commit that fixes it? I like to check if this is something that could affect MP2 as well.
     
    • Like Like x 1
  9. Sebastiii
    • Team MediaPortal

    Sebastiii Development Group

    Joined:
    November 12, 2007
    Messages:
    16,228
    Likes Received:
    6,189
    Gender:
    Male
    Location:
    France
    Ratings:
    +10,180 / 9
    Home Country:
    France France
    Show System Specs
    Hi @morpheus_xx
    Look at this commit, it's 100% ok for now but better, nope there is no deviceLost, i'm not sure what is the real issue except that when DRR kick in Intel stuff (audio and video are removed added but without creating a deviceLost)

    So : MP1-4781V11 : madVR V424 (Blackscreen rework when using DRR) · MediaPortal/MediaPortal-1@f72d13f · GitHub

    The workaround is to reduce and restore MP Form from the method : ForceMpAlive();
    And not sure really why but part of code line 1545 is needed : GUIGraphicsContext.DX9Device?.Present();

    So both are needed and should be executed when device is removed / added :p
     
    • Like Like x 1
  10. atlantic
    • Premium Supporter

    atlantic MP Donator

    Joined:
    January 9, 2008
    Messages:
    436
    Likes Received:
    62
    Gender:
    Male
    Location:
    Rennes
    Ratings:
    +106 / 1
    Home Country:
    France France
    Show System Specs
    Hi Sebastiii
    I've just installed "304128_MediaPortalSetup_1.18.100_madVR_V425.zip" and the blackscreen issue is resolved now. Thanks a lot.
    But now, I there is no sound watching some videos...
    Here the logs
     

    Attached Files:

    • Like Like x 2
  11. ilfesto

    ilfesto Portal Member

    Joined:
    May 10, 2010
    Messages:
    7
    Likes Received:
    0
    Ratings:
    +1 / 0
    I did same update, and sound to DTS + DTS HD is gone after this patch/update. Dolby Digital works
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!