[Bug] - XVID AVI Stuttering 1080p/50hz after about 20/25 minutes | Page 6

Discussion in 'MediaPortal 1.1.0 RC 1 & 2' started by robyf, March 18, 2010.

  1. robyf
    • Team MediaPortal

    robyf Retired Team Member

    Joined:
    June 20, 2005
    Messages:
    1,076
    Likes Received:
    139
    Occupation:
    IT Manager
    Location:
    Bolzano
    Ratings:
    +141 / 0
    Home Country:
    Italy Italy
    I've tried SVN 25496: the problem is still there although it seems there is a little bit less stuttering. Please let me know if there is something else I can do to help the developers to fix this problem.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Kotik
    • Premium Supporter

    Kotik MP Donator

    Joined:
    March 19, 2009
    Messages:
    699
    Likes Received:
    337
    Gender:
    Male
    Location:
    Athens
    Ratings:
    +555 / 2
    Home Country:
    Greece Greece
    Show System Specs
    I was playing around with codecs yesterday and i noticed something interesting.

    Are you using "Dynamic Refresh Rate" feature? If yes could you try to disable it. Then change the refresh rate manually over windows and play the file in Media Portal.

    See if that one improves things.
     
  4. robyf
    • Team MediaPortal

    robyf Retired Team Member

    Joined:
    June 20, 2005
    Messages:
    1,076
    Likes Received:
    139
    Occupation:
    IT Manager
    Location:
    Bolzano
    Ratings:
    +141 / 0
    Home Country:
    Italy Italy
    I've upgraded to RC2 and the problem unfortunately is still there.

    I still have to try disabling refresh rate changer as suggested...will try tomorrow.
     
  5. infinite.loop
    • Team MediaPortal

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    It would be extremelly helpful to know the exact last working version and the exact revison number of the version where the issue was first introduced.
     
  6. robyf
    • Team MediaPortal

    robyf Retired Team Member

    Joined:
    June 20, 2005
    Messages:
    1,076
    Likes Received:
    139
    Occupation:
    IT Manager
    Location:
    Bolzano
    Ratings:
    +141 / 0
    Home Country:
    Italy Italy
    I will try to compile SVN's before RC1 where there have been changes to directshowhelper and make some tests.... It can take some time, because a test for me has to run for 30 minutes to give the problem. Will let you know.

    Edit: I've seen I do not have to compile because dshowhelper.ddl comes already compiled... so it could take less time.

    Thanks
     
  7. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,113
    Likes Received:
    732
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,174 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Not pointing a finger or trying to blame someone. But I had the same feeling theese occasional stutters were introduced between the time Manfred improved the core.dll to tackle the "Haali Tray Icon issue" and when nyt improved EVR playback.
    This puts it, ofcourse based on my opinion/feeling, between:
    2009-10~15 - https://forum.team-mediaportal.com/...posed-after-stopping-video-56153/index16.html
    2010-01~18 - https://forum.team-mediaportal.com/...-after-refresh-rate-change-71311/index16.html

    Maybe thise timestamps are usefull in the search.
     
  8. robyf
    • Team MediaPortal

    robyf Retired Team Member

    Joined:
    June 20, 2005
    Messages:
    1,076
    Likes Received:
    139
    Occupation:
    IT Manager
    Location:
    Bolzano
    Ratings:
    +141 / 0
    Home Country:
    Italy Italy
    I do not think so because, as I said, if I use dshowhelper.dll from 24975 (last SVN before RC1) this particular problem disappear.

    I also have the feeling that other stuttering problems have to do with ati hack: if you don't have a good video card (ati4670 or similar) you will probably have stutter occasionally.
    I have bought an ATI 4670 six months ago and from there I did not have any stuttering until RC1.

    But this particular problem has nothing to do with ati hack, in my opinion.

    I suspect the problem has been introduced in SVN 25012: Fixed Mantis issue: 0002696: Fine tune EVR renderer scheduling parameters for lower end GPU/CPU.

    I will make tests tonight to confirm this suspect.
     
    • Like Like x 2
  9. jet70

    jet70 Portal Pro

    Joined:
    March 7, 2009
    Messages:
    95
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    England England
    I would just like to thank you robyf for looking into this - it is appreciated.
     
  10. edterbak
    • Team MediaPortal

    edterbak Test Group

    Joined:
    March 4, 2008
    Messages:
    2,113
    Likes Received:
    732
    Gender:
    Male
    Occupation:
    Researcher
    Ratings:
    +1,174 / 5
    Home Country:
    Netherlands Netherlands
    Show System Specs
    +1
    Thank you robyf for looking in to that indeed.
     
  11. robyf
    • Team MediaPortal

    robyf Retired Team Member

    Joined:
    June 20, 2005
    Messages:
    1,076
    Likes Received:
    139
    Occupation:
    IT Manager
    Location:
    Bolzano
    Ratings:
    +141 / 0
    Home Country:
    Italy Italy
    I still have no results but I'm working on it... just to keep you informed.
     
    • Like Like x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!