Best EPG for USA TV channels (1 Viewer)

corporate_gadfly

Portal Pro
May 17, 2011
396
136
Home Country
Canada Canada
Hey Corporate Gadfly. Couple questions for you.
When you use WEbGrap+Plus, have you been able to successfully get it to be an automated process so it updates etc and you don't have to go change the xml files or anything? I was reading your posts on the link you sent, but saw that you had to do some changes.
Yes, there is some initial tweaking to do, but once it is setup, I haven't had to touch it for the last few months. I do use a windows scheduled task to wake up the PC and grab the EPG using WebGrab+Plus for the next 8 days.[DOUBLEPOST=1362496264][/DOUBLEPOST]
Another kind user at ARGUS TV walks through the entire process. This combined with my link should get you going. Holler if you need more help. The key take away is to follow instructions in SiteIni.Pack.11.10/Networks/tvguide.com.no-provider_info.howtoaddprovider.txt.
 
Last edited:

ap90033

MP Donator
  • Premium Supporter
  • March 24, 2011
    198
    10
    Home Country
    United States of America United States of America
    Country flag
    To be honest, seems like everything for US epg (free that is) sucks. I have tried WebEPG WebGrab+, MCXML2, and nothing seems to just WORK was using Webgrab+ and yesterday it just stopped working. It imports new data into tv guide xml but MP XML importer just sits there saying "already importing". Meanwhile the TV Guide is BLANK and nothing will record. Sigh... I have for the past year tried and searched over and over and over and over and cannot find anything remotely close to a working solution. If it cannot get EPG and cant figure out what SEASON and EPISODE then whats the point??
     

    corporate_gadfly

    Portal Pro
    May 17, 2011
    396
    136
    Home Country
    Canada Canada
    By your own admission, the TV guide Xml is being populated, so the problem lies somewhere in MediaPortal since it refuses to import. Just trying to help here.
     

    ap90033

    MP Donator
  • Premium Supporter
  • March 24, 2011
    198
    10
    Home Country
    United States of America United States of America
    Country flag
    Not if xml file has bad or improperly formatted data... Just sayin'.. Anyway I am just a dumb user that has no clue why it stopped working. :)
     

    ap90033

    MP Donator
  • Premium Supporter
  • March 24, 2011
    198
    10
    Home Country
    United States of America United States of America
    Country flag
    Here is what i have fromwebgrab below. Attached are the Media portal logs....
    WebGrab+Plus/w MDB & REX Postprocess -- version 1.1.1/48 -- Jan van Straaten
    -----------------------------------------------------------
    Job started at 4/5/2013 1:39:53 PM
    Xmltv input file - C:\ProgramData\ServerCare\WebGrab\tvguide.xml - found
    0 superfluous shows removed
    Update requested for - 5 - out of - 5 - channels and for 14 day(s)
    Update mode set per individual channel
    Channel WITN-HD 7.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WITN-HD 7.1
    no changes, no update necessary !
    unchanged shows inspected 404
    total after update 404
    Channel WNCT-HD 9.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WNCT-HD 9.1
    no changes, no update necessary !
    unchanged shows inspected 392
    total after update 392
    Channel WNCTDT2 9.2 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WNCTDT2 9.2
    no changes, no update necessary !
    unchanged shows inspected 514
    total after update 514
    Channel WCTIH 12.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WCTIH 12.1
    no changes, no update necessary !
    unchanged shows inspected 417
    total after update 417
    Channel WYDOH 14.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WYDOH 14.1
    no changes, no update necessary !
    unchanged shows inspected 542
    total after update 542
    2269 shows in 5 channels
    0 updated shows
    0 new shows added
    Job finished at 4/5/2013 1:39:58 PM done in 4 seconds
     

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    908
    275
    SillyValley CA
    Home Country
    United States of America United States of America
    Country flag
    ap90033

    Getting USA EPG running can be frustrating. if you are trying to get WebGrab+Plus running I have a draft setup guide that shows the steps I follow to get WG++ running. See the following links.
    http://wiki.team-mediaportal.com/User:rond/WebGrab_Plus_Setup_Guide

    since we are both in the USA you need to get a local SRVID and setup a custom tvguide.com.no-provider.ini file to get full local station listings
    http://wiki.team-mediaportal.com/Us...Setup_Guide/Customize_TVguide.com.no-provider

    looking at your error.log, I noticed the following error.
    Exception :confused:ystem.IO.FileNotFoundException: Could not find file 'C:\ProgramData\ServerCare\WebGrab\tvguide.lst'.
    unless you are using a TVguide.lst file you should make sure you have that option disabled in your xmltv > General settings.
    http://wiki.team-mediaportal.com/1_...e_Setup_(EPG)/XMLTV_mc2xml#Setup_XMLTV_Plugin
    But looking in your tv.log file it shows the following, so I think xmltv is also looking for tvguide.xml file but it is not finding any programs
    plugin:xmltv importing C:\ProgramData\ServerCare\WebGrab\tvguide.xml

    In your WebGrab+Plus Data folder do you have a tvguide.xml file? by default WG++ writes EPG data to guide.xml. I copy guide.xml to tvguide.xml so xmltv will import the EPG data. The WG++ log info you provided shows the 5 channels have 300-500 shows in tvguide.xml

    could you upload the WG++ config files you are using so I can take a look and see if they work for my test system. WebGrab++.config.xml and the TVGUIDE.COM.EASTERN file. Also what WG++ version are you using?

    I'll be around all afternoon if you want to try getting this working, maybe double check your WG++ setup using the WG++ wiki guides.
     

    ap90033

    MP Donator
  • Premium Supporter
  • March 24, 2011
    198
    10
    Home Country
    United States of America United States of America
    Country flag
    Well as a temp measure I switched back to WebEPG and got that working. I dont really care which I use to be honest just want shows recorded on time and it would be GREAT if they could have Season and Episode number (ex S01E12).. I have attached my wg config files and i am using the latest with 48...
     

    Attachments

    • tvguide.com.eastern.channels.xml
      3 KB · Views: 253
    • WebGrab++.config.xml
      9.4 KB · Views: 196

    RonD

    Test Group
  • Team MediaPortal
  • December 20, 2011
    908
    275
    SillyValley CA
    Home Country
    United States of America United States of America
    Country flag
    glad at least WebEPG works for your location. I was curious why WG++ did not work so I made test case for your area. Looked up the zip for WITN = 27889, found the tvguide.com srvid = 20460.268435456 for that area, generated the channels.xml file and updated the WG config file. I ran WG++ to grab 3 days of listings for the 5 channels you showed. When I mapped the tvguide.xml file to some unused local channels with xmltv I was able to import the channels and they showed valid TV Guide info in the MePo EPG. The attached zip has the WG++ config files I used and the tvguide.xml file. Not sure why you problems when you tried it.
     

    Attachments

    • WG_test.zip
      56.7 KB · Views: 357

    Cruzer

    Portal Pro
    February 16, 2008
    172
    15
    Home Country
    United States of America United States of America
    Country flag
    I've been using mc2xml along with with the xmltv plugin in the TV server. This has served me well for many years. As with most of these solutions, there is some work in getting it going. Not the best data for the EPG, but adequate.
     

    Users who are viewing this thread

    Similar threads

    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system hdd and decided it was time for a clean install anyway. Other hardware (C2D, 8 Gb ram, no tv cards - IP only) unchanged. Was running an earlier Win10 version with MP 1.24 which had been updated for years...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Having used MP1 since 15 years, these epg related problems occuring after a fresh install stumble me. Needed to change a system...
    Replies
    0
    Views
    272
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my office machine MP client. Same exact network, firewall, Defender settings. It's a slightly older version of Win 10 though - I haven't updated to 20Hx on it yet. Maybe I shouldn't (or maybe I should image it...
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my...
    Let me start by asking if anyone has TV Server running PROPERLY on a Windows 10 machine, and if so are you using RTSP or UNC share...
    Replies
    9
    Views
    470
    I think MPExtended need rework for support this - andrewjswan/MPExtended Maybe better direct select to TV SQL DB? Or look how MPExtended get this info ...
    I think MPExtended need rework for support this - andrewjswan/MPExtended Maybe better direct select to TV SQL DB? Or look how...
    Hi everyone, I am hoping someone can help with the following. I am based in the UK. I have a family member who has a disability...
    Replies
    7
    Views
    598
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this year, in march 2020) the Telenet provider will stop broadcasting Analog TV and Radio signals on their cable, and make the switch to Digital (DVB-C). The radio signals will disappear completely, so you'll...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    Replies
    0
    Views
    699
    Sorry, i dont use TV in Mediaportal at all. :) -- WBR, ajs :):whistle::coffee:
    Sorry, i dont use TV in Mediaportal at all. :) -- WBR, ajs :):whistle::coffee:
    Love MediaPortal 1! I've been using it for years, originally with the MePo client and for the last few years as a backend for...
    Replies
    4
    Views
    1K
    Top Bottom