Best EPG for USA TV channels | Page 2

Discussion in 'Electronic Program Guide' started by Eric B, March 3, 2013.

  1. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    Yes, there is some initial tweaking to do, but once it is setup, I haven't had to touch it for the last few months. I do use a windows scheduled task to wake up the PC and grab the EPG using WebGrab+Plus for the next 8 days.[DOUBLEPOST=1362496264][/DOUBLEPOST]
    Another kind user at ARGUS TV walks through the entire process. This combined with my link should get you going. Holler if you need more help. The key take away is to follow instructions in SiteIni.Pack.11.10/Networks/tvguide.com.no-provider_info.howtoaddprovider.txt.


     
    Last edited: March 20, 2013
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. ap90033
    • Premium Supporter

    ap90033 MP Donator

    Joined:
    March 24, 2011
    Messages:
    197
    Likes Received:
    5
    Ratings:
    +6 / 0
    Home Country:
    United States of America United States of America
    To be honest, seems like everything for US epg (free that is) sucks. I have tried WebEPG WebGrab+, MCXML2, and nothing seems to just WORK was using Webgrab+ and yesterday it just stopped working. It imports new data into tv guide xml but MP XML importer just sits there saying "already importing". Meanwhile the TV Guide is BLANK and nothing will record. Sigh... I have for the past year tried and searched over and over and over and over and cannot find anything remotely close to a working solution. If it cannot get EPG and cant figure out what SEASON and EPISODE then whats the point??
     
  4. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    By your own admission, the TV guide Xml is being populated, so the problem lies somewhere in MediaPortal since it refuses to import. Just trying to help here.
     
  5. ap90033
    • Premium Supporter

    ap90033 MP Donator

    Joined:
    March 24, 2011
    Messages:
    197
    Likes Received:
    5
    Ratings:
    +6 / 0
    Home Country:
    United States of America United States of America
    Not if xml file has bad or improperly formatted data... Just sayin'.. Anyway I am just a dumb user that has no clue why it stopped working. :)
     
  6. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    Ah... missed the part about corrupt XML. Anything in the WebGrab+Plus logs? If you find something fishy you could post it here or at the WebGrab+Plus forum.
     
  7. ap90033
    • Premium Supporter

    ap90033 MP Donator

    Joined:
    March 24, 2011
    Messages:
    197
    Likes Received:
    5
    Ratings:
    +6 / 0
    Home Country:
    United States of America United States of America
    Here is what i have fromwebgrab below. Attached are the Media portal logs....
    WebGrab+Plus/w MDB & REX Postprocess -- version 1.1.1/48 -- Jan van Straaten
    -----------------------------------------------------------
    Job started at 4/5/2013 1:39:53 PM
    Xmltv input file - C:\ProgramData\ServerCare\WebGrab\tvguide.xml - found
    0 superfluous shows removed
    Update requested for - 5 - out of - 5 - channels and for 14 day(s)
    Update mode set per individual channel
    Channel WITN-HD 7.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WITN-HD 7.1
    no changes, no update necessary !
    unchanged shows inspected 404
    total after update 404
    Channel WNCT-HD 9.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WNCT-HD 9.1
    no changes, no update necessary !
    unchanged shows inspected 392
    total after update 392
    Channel WNCTDT2 9.2 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WNCTDT2 9.2
    no changes, no update necessary !
    unchanged shows inspected 514
    total after update 514
    Channel WCTIH 12.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WCTIH 12.1
    no changes, no update necessary !
    unchanged shows inspected 417
    total after update 417
    Channel WYDOH 14.1 site -- TVGUIDE.COM.EASTERN -- update mode incremental
    Summary for update of WYDOH 14.1
    no changes, no update necessary !
    unchanged shows inspected 542
    total after update 542
    2269 shows in 5 channels
    0 updated shows
    0 new shows added
    Job finished at 4/5/2013 1:39:58 PM done in 4 seconds
     
  8. RonD
    • Team MediaPortal

    RonD Test Group

    Joined:
    December 20, 2011
    Messages:
    904
    Likes Received:
    119
    Occupation:
    semi-pro slacker
    Location:
    SillyValley CA
    Ratings:
    +275 / 0
    Home Country:
    United States of America United States of America
    ap90033

    Getting USA EPG running can be frustrating. if you are trying to get WebGrab+Plus running I have a draft setup guide that shows the steps I follow to get WG++ running. See the following links.
    http://wiki.team-mediaportal.com/User:rond/WebGrab_Plus_Setup_Guide

    since we are both in the USA you need to get a local SRVID and setup a custom tvguide.com.no-provider.ini file to get full local station listings
    http://wiki.team-mediaportal.com/Us...Setup_Guide/Customize_TVguide.com.no-provider

    looking at your error.log, I noticed the following error.
    Exception :confused:ystem.IO.FileNotFoundException: Could not find file 'C:\ProgramData\ServerCare\WebGrab\tvguide.lst'.
    unless you are using a TVguide.lst file you should make sure you have that option disabled in your xmltv > General settings.
    http://wiki.team-mediaportal.com/1_...e_Setup_(EPG)/XMLTV_mc2xml#Setup_XMLTV_Plugin
    But looking in your tv.log file it shows the following, so I think xmltv is also looking for tvguide.xml file but it is not finding any programs
    plugin:xmltv importing C:\ProgramData\ServerCare\WebGrab\tvguide.xml

    In your WebGrab+Plus Data folder do you have a tvguide.xml file? by default WG++ writes EPG data to guide.xml. I copy guide.xml to tvguide.xml so xmltv will import the EPG data. The WG++ log info you provided shows the 5 channels have 300-500 shows in tvguide.xml

    could you upload the WG++ config files you are using so I can take a look and see if they work for my test system. WebGrab++.config.xml and the TVGUIDE.COM.EASTERN file. Also what WG++ version are you using?

    I'll be around all afternoon if you want to try getting this working, maybe double check your WG++ setup using the WG++ wiki guides.
     
  9. ap90033
    • Premium Supporter

    ap90033 MP Donator

    Joined:
    March 24, 2011
    Messages:
    197
    Likes Received:
    5
    Ratings:
    +6 / 0
    Home Country:
    United States of America United States of America
    Well as a temp measure I switched back to WebEPG and got that working. I dont really care which I use to be honest just want shows recorded on time and it would be GREAT if they could have Season and Episode number (ex S01E12).. I have attached my wg config files and i am using the latest with 48...
     

    Attached Files:

  10. RonD
    • Team MediaPortal

    RonD Test Group

    Joined:
    December 20, 2011
    Messages:
    904
    Likes Received:
    119
    Occupation:
    semi-pro slacker
    Location:
    SillyValley CA
    Ratings:
    +275 / 0
    Home Country:
    United States of America United States of America
    glad at least WebEPG works for your location. I was curious why WG++ did not work so I made test case for your area. Looked up the zip for WITN = 27889, found the tvguide.com srvid = 20460.268435456 for that area, generated the channels.xml file and updated the WG config file. I ran WG++ to grab 3 days of listings for the 5 channels you showed. When I mapped the tvguide.xml file to some unused local channels with xmltv I was able to import the channels and they showed valid TV Guide info in the MePo EPG. The attached zip has the WG++ config files I used and the tvguide.xml file. Not sure why you problems when you tried it.
     

    Attached Files:

    • WG_test.zip
      File size:
      56.7 KB
      Uploaded:
      April 6, 2013
      Views:
      339
  11. Cruzer

    Cruzer Portal Pro

    Joined:
    February 16, 2008
    Messages:
    172
    Likes Received:
    15
    Ratings:
    +15 / 0
    Home Country:
    United States of America United States of America
    I've been using mc2xml along with with the xmltv plugin in the TV server. This has served me well for many years. As with most of these solutions, there is some work in getting it going. Not the best data for the EPG, but adequate.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!