Help with xmltv (1 Viewer)

donmega

Portal Member
November 14, 2005
42
0
I keep getting an error when trying to setup xmltv

Error says
ERROR: Number of days but not be negative


Trying to setup for NA


Thanks
 

Marcusb

Retired Team Member
  • Premium Supporter
  • February 16, 2005
    1,995
    29
    Melbourne
    in the XMLTV.config file, what are your settings for the number of days?

    By default it should be 7 days for downloading and I think it is set to keep the previous three days as history.

    (you probably already know this, but use notepad to open the .config file)
     

    donmega

    Portal Member
    November 14, 2005
    42
    0
    I dont seem to have an xml config file.

    Where should it be located?
    C:\Program Files\Team MediaPortal\MediaPortal\xmltv ?
     

    Marcusb

    Retired Team Member
  • Premium Supporter
  • February 16, 2005
    1,995
    29
    Melbourne
    OK, I was working from memory before...

    In Australia, we have a tvharvest.exe that builds the XMLTV file. Depending on what program you use to get the XMLTV file things may be different.

    In the XMLTV directory, there is a tvharvest.exe file and a tvharvest.exe.config file. the config file is where you specify things like the number of days to download in advance and it sounds like this is where your error is coming from.

    Here is my setup:

    Code:
    		<add key="days" value="10" />
    		
    		<add key="pastdays" value="3" />

    If this doesn't help, let us know what steps you are taking so far.
    Also, I'm feeling very stupid here, but when you say you are trying to set up for NA do you mean North America?
     

    donmega

    Portal Member
    November 14, 2005
    42
    0
    I used this guide
    http://nolanparty.com/mediaportal.sourceforge.net/phpBB2/viewtopic.php?t=313

    and it appears to be working, but I did get the Program Guide section of media portal setup to do the dirt work for me before.

    Dont know why its not any more, just keeps giving me that error.

    I hope with using that guide the the tvguide will still auto update.

    Gonna suck if I have to redo it every couple of days.

    Any input ?
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 [solved] XMLTV Channel Selection DE
    Thanks jfd553, Yes, I figured out it does download from Schedules Direct. I had done what you suggested and checked my download file for that specific channel number and could not find it. So I submitted a request to update the Schedules Direct data for my area. Took a few weeks but I just heard back 3 days ago that it had been...
    Thanks jfd553, Yes, I figured out it does download from Schedules Direct. I had done what you suggested and checked my download...
    I am using MP 2.4.1 on Windows 10. I use the XMLTV plugin with Schedules Direct to get my Guide data. In the TV setup interface...
    Replies
    3
    Views
    378
    If you search in forum for "0x80070643" you find several threads with solutions. [solved] - Fatal Error 0x80070643 during MP2 installation MP2 - V2.4.1 - [solved] - MP2-V2.4.1 Installation crashes
    If you search in forum for "0x80070643" you find several threads with solutions. [solved] - Fatal Error 0x80070643 during MP2...
    Greetings All - newbie here I'm getting an error when attempting to install MP2: Error 1064: An Exception occurred in the service...
    Replies
    1
    Views
    331
    https://issues.team-mediaportal.com/browse/MP1-5113
    https://issues.team-mediaportal.com/browse/MP1-5113
    I am trying to configure the TV Server for the first time, without success. It picks up the dual DVB-T tuners but when I try to...
    Replies
    6
    Views
    860
    thank you very much for your quick response. Obviously 1.30 seems to support wifiRemote and mpextented so I can continue to use MPiviewer for ipad and that's what was important to me. it's nice to have taken the time for my problem which will undoubtedly be useful to others as well.
    thank you very much for your quick response. Obviously 1.30 seems to support wifiRemote and mpextented so I can continue to use...
    Hello, I am trying to reinstall mediaportal 1.16 but I get an error message "no internet connection found! to continue the...
    Replies
    12
    Views
    752
    Hello, thank you for you logs, but bd log is empty ( except 2 lines ) maybe one stuff will be to update the libbluray library, but it's long work for me, and to be honest i doesn't have motivation. if finally worked for you , i'm glad. personnaly, i know on BD drive i have, was a mess to work because of the BD disc driver was not...
    Hello, thank you for you logs, but bd log is empty ( except 2 lines ) maybe one stuff will be to update the libbluray library...
    I'm trying to play the Blu-ray Doctor Who - Flux and both disk 1 and disk 2 simply freeze MePo 1.30. I waited about 4- minutes...
    Replies
    4
    Views
    615
    Top Bottom