[WiP] madVR support in MP1 (4 Viewers)

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    @daWooky
    Hi,
    I have found what does Auto3D plugin lol.
    In fact when we tell to analyse the video stream, it use FrameGrabber from MP and does the analyse lol and that trigger the flicker.
    So if we uncheck the option for analysing the video -> no more issue, in fact this analyse will work only in D3D9 if i'm not wrong for madVR :p
     

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    nice discovery m8, thanks
    but it's been a while since i've had auto3d enabled on the htpc :)
    so no idea if I had it last with auto detection or on manually.. i'll try tomorrow ;)
     

    daWooky

    MP Donator
  • Premium Supporter
  • April 3, 2012
    779
    868
    Germany Germany
    Country flag
    hi @Sebastiii
    played once more with auto3d enabled yesterday and unfortunately i didn't notice any difference if analysis is ticked or not.:p
    but this htpc is also nearly 100% flicker free (all downscaling with DXVA) so im not so shure anymore which of the flickers is it you described before^^
    and one good (or bad^^) thing is that now i know again why i had deactivated the auto3d plugin earlier :LOL:
    because it seems to interfere heavily with 3d-framepacked videos.
    if enabled it did make a mess on start playing 3d-fp. (acts like with stopmotion style and half 3d ^^) and even the mepo commands (pause, stop, back....) are delayed. until a execution it feels like a 20 seconds delay... and madvr crashed :whistle: report attached
    the run was with auto3d was enabled-> playing a framepacked 3d-mkv -> changed directly without manual stop in between to a framepacked 3d-iso -> no 3d i think exclusive mode was lost or dx11 idk. -> stuttering playback -> blackscreen with madvr crash on stopping...
    it was ok to use auto3d plugin with sbs/tab stuff, also with other non 3d videos, it all seems playing ok and the 3d detection works flawlessly..
    but personally, i always tend to prefer the framepacked 3d stuff if possible, i may can do all that manually, if i had to watch a sbs video but tbh. i wont be in the mood to do so and if it better be called manu3d... anyway 3d-fp. is just so much better^^ idk. maybe its possible to disable the whole 3d framepacked stuff within the auto3d plugin in general? :sneaky:

    cheers m8
     

    Attachments

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,447
    10,273
    France
    France France
    Country flag
    I have done some change on MP locally for auto 3d that describe your issue. So will try to make a build on the week end. I'm on business trip and back Friday night. :)

    From Tapatalk
     

    Kotik

    MP Donator
  • Premium Supporter
  • March 19, 2009
    699
    485
    Athens
    Greece Greece
    Hello Sebastiii,

    I think i found an annoying old problem that was not there in previous builds but is back now....

    After watching a video for extended time, when i press STOP or the video ends i get a black screen with MP running in the background, i can hear my navigation clicks and a forced MP close doesnt solve the black screen :-(

    I have to restart my pc to fix it. I would love to provide u with logs but they are HUGE cause it is hard to reproduce, if i just watch 10 minutes the issue doesnt happen.

    Sent from my GT-I9100 using Tapatalk
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 4)

    OP Similar threads Forum Replies Date
    T MadVR + LAV Filters, Perfect in MPC-BE, Bad in MP1 MediaPortal 1 Talk 13
    A 1.24.0 1.24 Kills 3D MVC playback on MadVr 1.24-1.26 Pre Release 66
    X MadVR Settings Video & DVD 2
    G MadVR, black TV Picture 1.20 Pre Release 1
    S Pause button no longer works with MadVR in 1.19 General Support 4
    C Is there an ideot save how-to implement madVR incl. HDR? Codecs, External Players 1
    Palm_Maniac madVR Frage Allgemeines Supportforum 19
    horned_reaper [solved] HID commands are not processed when multiple applications with HID support are open General Support 16
    horned_reaper [solved] Add support for Bluetooth events Improvement Suggestions 2
    CyberSimian Support for control.isvisible() in expressions MediaPortal 1 8
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 14
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    J Support waipu TV TV-Server 0
    doskabouter WebDAV support OnlineVideos 0
    K Multichannel audio and subtitles for TV not properly supported General Support 4
    CyberSimian Support pack for Ortek VRC-1100 and Hama 00052451 Remotes 6
    cbr954rr [Finished] [MP2-801] Support for tag image extraction Archive 7
    catavolt [solved] FanartHandler - Skin - Holiday and Spotlight support Fanart Handler 14
    C Drive Type is not supported by system Allgemeines Support- und Diskussionsforum 3
    raffe [solved] Export tool and import support from MP-TVSeries & Moving Pictures to MP2 General 22
    morpheus_xx General Testing TVE 3.5 Sat>IP support (MP2 only) TV Engine 47
    E M3U Playlist and EPG Support/Configuration Installation, configuration support 1
    G Mediaportal2 supported formats General 1
    M [solved] Stub Support General 11
    morpheus_xx [WiP] Adding 64 bit support to MP2 MediaPortal 2 31
    Similar threads

























    Top Bottom