MP crashed with VC++ runtime error (1 Viewer)

petsa

MP Donator
  • Premium Supporter
  • January 23, 2007
    588
    15
    Stockholm
    Home Country
    Sweden Sweden
    Hi gibman,

    Have you had any chance to look anymore into the suspicious SVN? I'd be happy to test but I don't know how to make a build without the problematic SVN.

    /Peter
     

    Seidelin

    Retired Team Member
  • Premium Supporter
  • August 14, 2006
    1,755
    652
    Kgs. Lyngby
    Home Country
    Denmark Denmark
    Country flag
    It is must likely related to the usage of "remember last active module".

    I reverted "SVN 20891 - texture manager change"

    seems to fix it ...

    no more onresume problems on "remember last active module" for me.

    Can any1 confirm ?

    /gibman

    I saw this issue once, but I do not have remember last active module activated.
    Logs in pastebin
     

    nicksti

    Portal Pro
    September 1, 2006
    68
    1
    hello,
    same problem by me with latest svn but only after wakeup for recording. After waking up with keyboard or remote control I haven't had the problem.
     

    petsa

    MP Donator
  • Premium Supporter
  • January 23, 2007
    588
    15
    Stockholm
    Home Country
    Sweden Sweden
    I think I got something here...

    Out of curiousity I changed to another skin (Indigo) earlier today and all of a sudden I do not get these crashes anymore... Then I changed to Blue3, then Blue3wide, still no crashes. So I changed back to XmasBlue3Wide that I had originally and immediatly I got a crash upon resume.

    Can anyone else confirm the chosen skin has something to do with this?

    /Peter
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    I think I got something here...

    Out of curiousity I changed to another skin (Indigo) earlier today and all of a sudden I do not get these crashes anymore... Then I changed to Blue3, then Blue3wide, still no crashes. So I changed back to XmasBlue3Wide that I had originally and immediatly I got a crash upon resume.

    Can anyone else confirm the chosen skin has something to do with this?

    Sounds like a pure luck with the results :D

    Main issue is coming from the texture manager changes (fixes actually). Its most likely just different timing that amount of the textures (and their sizes) are triggering the bug.
     

    Users who are viewing this thread

    Similar threads

    @ultimatejoe If you could post an export file with your TV channels and radio stations, I can try adding the logos to LogoManager.
    @ultimatejoe If you could post an export file with your TV channels and radio stations, I can try adding the logos to LogoManager.
    MediaPortal is crashing on startup. This problem started yesterday; I hadn't made any changes to the software, installed any...
    Replies
    10
    Views
    2K
    • Locked
    Indeed. My concern was that neither 2.1.3 Pre-Release, nor 2.2 development currently result in a successful installation in this situation, and that people may preferentially view 2.1.3 as the current stable.
    Indeed. My concern was that neither 2.1.3 Pre-Release, nor 2.2 development currently result in a successful installation in this...
    Hello all, I would like to try MediaPortal 2, but have run into a show stopping installation bug. The installation fails with...
    Replies
    19
    Views
    3K
    I'm using a hdmi detective for years now. Don't know if that has something to do with this?
    I'm using a hdmi detective for years now. Don't know if that has something to do with this?
    Hi Seb I don't know if you are still interested but I'm getting MP crashes on resume from sleep on a fairly regular basis. I can do...
    Replies
    92
    Views
    10K
    Anecdotal testimonies are not helpful. If you guys would like to continue this chat, I'll move this thread to the Café section. The discussion about your issues is taking place here: Installation failing
    Anecdotal testimonies are not helpful. If you guys would like to continue this chat, I'll move this thread to the Café section...
    I have been looking for a replacement to Windows Media Center for a little over a year.No luck. Now, I'm no Microsoft fanboy, but I...
    Replies
    15
    Views
    2K
    How are things going Jamie? Have you given up, or are you just busy?
    How are things going Jamie? Have you given up, or are you just busy?
    I have so many symptoms that I am wondering if I shouldn't just uninstall and wipe everything and start over. #4 below is the only...
    Replies
    11
    Views
    2K
    Top Bottom