no standby at night (1 Viewer)

harryzwo

Portal Pro
July 25, 2006
714
64
Germany Germany
Country flag
since about 2 weeks my HTPC is running every morning. When i turned PC on via FB -> PC goes in standby.
So there is no reason to prevent Standby. In LOG i coulnd see anything.
 

Attachments

HTPCSourcer

MP2 Product Manager
  • Team MediaPortal
  • May 16, 2008
    11,431
    2,333
    Germany Germany
    Country flag
    Next time that you find your PC running, open an administrative command or powershell window and enter

    powercfg -lastwake

    This will then display what exactly is waking up your PC.
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    I did this a few days ago.
    Powercfg replayed 'TVSERVICE'. In this night there was a recording with no standby after it.
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    After ending Record HTPC have to go in AWAYMODE? is this Right. in TVSERVERLOG i found changeing in idle state.

    [2019-06-02 01:35:01,143] [Log ] [PS StandbyWakeup] [INFO ] - PS: System changed from busy state to idle state

    Can this be the reason of nostandby?
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,021
    1,253
    Southampton
    United Kingdom United Kingdom
    Country flag
    I see from your "System Specs" that you are using Windows 10. From what I have read elsewhere, Windows 10 has a tendency to reset the power-plan settings everytime a Windows update occurs. If your HTPC was working correctly, and it started misbehaving two weeks ago, could it have been due to a Windows 10 update?

    I would suggest reviewing carefully all of your power-plan settings, to make sure that they are what you think they should be. Note that away mode should be enabled.

    Are you using the "PowerScheduler" plugin? I would suggest using it in "plug and play" mode, with the "HTPC" plan selected.

    If none of that works, install Windows 7.

    -- from CyberSimian in the UK
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    I think i have found the Reason.
    I send MP to Standby with FB. it seems that MP-Client not closed. So after resume by TVSERVICE timeshifting begins and HTPC didn't go to Standby anymore.
     

    harryzwo

    Portal Pro
    July 25, 2006
    714
    64
    Germany Germany
    Country flag
    is there any possibility to close MP-Client via Batch while clicking 'all off' on FB? It seems so that MP-Client not automaticly close when HTPC goes to standby.
     

    CyberSimian

    Test Group
  • Team MediaPortal
  • June 10, 2013
    2,021
    1,253
    Southampton
    United Kingdom United Kingdom
    Country flag
    is there any possibility to close MP-Client via Batch while clicking 'all off' on FB?
    The client part of "PowerScheduler" looks like you can specify a BAT file that you want to run when the HTPC is about to standby. I say "looks like", as the Wiki is not clear on what is supported :(. (Or to put that another way, I don't understand it :(.) Start here and see if it helps you.

    On my system, I do something similar to what you want, but I don't use "PowerScheduler" to run the BAT file (I have a very convoluted setup to manage power-state changes). There may be other ways of closing the MP client, but the way that I use is for the BAT file to run an AutoHotKey script. The script sends keyboard shortcuts to the MP window to stop playback, invoke the exit dialogue, and select "close MP". My script won't work for you (it is too specific to my setup), but if you are a programmer you could write your own script to do the equivalent.

    -- from CyberSimian in the UK
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom