Onlinevideos crash MP when I try to play something from SVT Play (1 Viewer)

styrsven

Portal Pro
January 6, 2013
115
51
59
Sweden Sweden
Country flag
Hi, as the title says, this is what happens. I select something to watch, the buffering starts, and then it crashes.
Logfiles attached.
 

Ministerk

Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    I can't take a look at this at the moment, vacation. Does mp crash only playing SVTPlay content? Have you tried UR Play, DPlay, Viasat or TV4 Play? Can you play local content; what if you download from SVTPlay and play the downloaded content? (To be able to see the dowloaded content you have to add .f4m as video content in mediaportal settings).
     

    styrsven

    Portal Pro
    January 6, 2013
    115
    51
    59
    Sweden Sweden
    Country flag
    I have since I reported this updated to 1.15, but the problem persists. Some time ago I tried the madvr builds, including the onlinevideos version, but have since restored the standard version, including onlinevideos. I have reinstalled onlinevideos several times.
    TV (MP tv-server with Argus scheduling), moving pictures and mytvseries all work fine, but onlinevideos crash, I tried youtube and locally saved material, but it all crashes.
    I remember that onlinevideos have worked, just a few weeks ago, but now it crashes MP.
     

    styrsven

    Portal Pro
    January 6, 2013
    115
    51
    59
    Sweden Sweden
    Country flag
    This look suspicuous... (OnlineVideos.log in the attachment above)

    [06-27 06:51:07,445] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> LAV Video Decoder --> Enhanced Video Renderer
    [06-27 06:51:07,496] [MPMain ] [DEBUG] MediaPortal Url Source Splitter --> LAV Audio Decoder --> MediaPortal - Audio Renderer
    [06-27 06:51:07,504] [MPMain ] [WARN ] System.MissingMethodException: Metoden hittades inte: VideoRendererType MediaPortal.GUI.Library.GUIGraphicsContext.get_VideoRenderer().
    vid OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.AdaptRefreshRateFromCacheFile()
    vid OnlineVideos.MediaPortal1.Player.OnlineVideosPlayer.Play(String strFile)
    vid MediaPortal.Player.g_Player.Play(String strFile, MediaType type, TextReader chapters, Boolean fromPictures, Int32 title, Boolean forcePlay, Boolean fromExtTS)
    vid OnlineVideos.MediaPortal1.GUIOnlineVideos.Play_Step6(PlayListItem playItem, String lsUrl, PlayerFactory factory)
    [06-27 06:51:07,731] [MPMain ] [INFO ] OnlineVideosPlayer: Stop
    [06-27 06:51:09,511] [OVPlaying ] [INFO ] Setting Video Properties for 'Vi hade i alla fall tur med vädret Vi hade i alla fall tur med vädret'
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    825
    Uppsala
    Sweden Sweden
    Country flag
    Some time ago I tried the madvr builds, including the onlinevideos version
    I think this is the problem (and cached installers).
    Could you try to:
    • Uninstall OV agian
    • Remove all OnlineVideos related stuff (.dll and folder) )in C:\Program Files (x86)\Team MediaPortal\MediaPortal\plugins\Windows\
    • Open MediaPortal Extensions Manager (MPEM)
    • Clean the MPEM cache
    • Refresh update info
    • Install OnlineVideos
     

    styrsven

    Portal Pro
    January 6, 2013
    115
    51
    59
    Sweden Sweden
    Country flag
    Actually, the onlinevideo fix for madvr was only a dll, so that was easy to restore. I think there were some other leftover that created problems. Anyway, due to unforeseen events (=fumblefingers), I had to do a total reinstall and now all is working again.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    A OnlineVideos MediaPortal 1 Plugins 3
    morpheus_xx [WiP] OnlineVideos: New browser based playback support using WebDriver, new Amazon siteutil MediaPortal 2 14
    bta489 [solved] System goes to Standby during Amazon Prime Playback OnlineVideos 2
    J Debug OnlineVideos, How To? OnlineVideos 1
    Predpray OnlineVideo 2 Probleme Allgemeines Support- und Diskussionsforum 12
    HTPCSourcer MP2 OnlineVideos Overhaul MediaPortal 2 46
    HTPCSourcer OnlineVideos is not remembering my sites MediaPortal 2 25
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    E OnlineVideo Plugins - eigene Videostreams hinzufügen Plugins & Erweiterungen 0
    A MediaPortal crash (and restart) on LiveTV after Windows Update (Sep 2020) driver update for Intel HD Graphics 4600 General Support 0
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    L Service keeps crashing General 5
    U [solved] MediaPortal crashing on startup General Support 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    W [solved] MP suddenly Crashes when starting live TV on most channels and on recordings from the same channels General Support 20
    W [solved] MP suddenly Crashes when starting live TV on some channels and on some recordings Television (MyTV frontend and TV-Server) 1
    D [solved] Changed username in Win10, now TV Server config crashes on fresh install Installation, configuration support 1
    ajs Trakt error when start with MP crash Trakt 1
    R TV server crash with WintTV quadHD General 0
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    atlantic [solved] MP1.24 Pre released crash in TV General Support 12
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    R [fixed] [MP2-819] MP2 Server crashes on ATSC OTA channel scan Submit: Bug Reports 33
    doskabouter 1.23.0 Crash when skipping in a dvd Bugreports 3
    Similar threads

























    Top Bottom