Problem importing 'X:enius' series. (1 Viewer)

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,434
    1,897
    i have a problem. Your plugin dont load a serie. http://thetvdb.com/index.php?tab=series&id=269470&lid=14

    The problem is with TheTVdB website. They do not offer any way to locate that show called "X:enius" via their API. Reason being is the ':' character that throws things off as it is a reserved filename character for Windows OS (and others).

    These all fail:
    So you need to contact TheTVdB on their forum and ask them if they can look into it. They need to convert the ':' character to allow for a search indirectly; most obvious one would be to strip it, so one can look for "Xenius". Can be solved by fixing their API or simply adding 'Xenius' as alternative title to the database. Only TheTVdB mods and/or admins can do that, so you need to contact them. Once they fix it, then within a short time it will automatically work for MP-TVSeries.
     

    Data45000

    Portal Pro
    February 11, 2011
    602
    14
    Here
    Home Country
    Germany Germany
    The answer from the TVDB Forum:

    There's nothing to fix. If the series name is entered correctly and your scraper isn't capable of processing it due to a colon then you will need to contact the developer and inquire about a fix. We don't incorrectly edit series names to work around bugs in other people's software.
     

    Edalex

    Community Plugin Dev
  • Premium Supporter
  • January 3, 2008
    2,955
    1,264
    Saratov
    Home Country
    Russian Federation Russian Federation
    The answer from the TVDB Forum:

    There's nothing to fix. If the series name is entered correctly and your scraper isn't capable of processing it due to a colon then you will need to contact the developer and inquire about a fix. We don't incorrectly edit series names to work around bugs in other people's software.
    They know that api search is sucks as I remember.
    Obviously that hikaricore didn't understand that the problem in not in the mp-tvseries.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,434
    1,897
    The answer from the TVDB Forum:

    There's nothing to fix. If the series name is entered correctly and your scraper isn't capable of processing it due to a colon then you will need to contact the developer and inquire about a fix. We don't incorrectly edit series names to work around bugs in other people's software.

    Tell them to give you the TheTVdB API instructions then to make it work. Even adding a colon does not give any usable results as per:

    And that is *their* system failing, not MP-TVSeries.
     

    Data45000

    Portal Pro
    February 11, 2011
    602
    14
    Here
    Home Country
    Germany Germany
    Answer from site admin
    That's not true. Our site works just fine with colons and can return X:enius using our API. The problem is MP doesn't allow you to search for a series with a colon in it.
    Example: http://www.thetvdb.com/api/GetSeries.ph ... anguage=de

    I did add Xenius as a hidden AKA though, so now it can match to Xenius but still return "X:enius". Just to be clear MP can add support for colons on their end if they want to, it gets awkward for them though since they get their names off file names and many file systems don't allow colons. We however fully support colons on our end.

    But now it is found!!!! :)
     
    Last edited:

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,434
    1,897
    LOL, the API search that failed all this time, now magically works, and they keep insisting it was MP-TVSeries fault.

    I did add English description yesterday, then their system freaked out on me for not specifying an English title (thought that was only needed when title was different from the existing entry). And now when visiting http://thetvdb.com/index.php?tab=series&id=269470 it seems they fixed that title part and now things magically work again.

    So perhaps their API (search part anyway) only really works on entries that have an English definition set, even when the show is purely foreign. This does mean in the future anybody with a TheTVdB account can correct this by adding an English entry. Unless the real fix was them adding the hidden entry and it is just a big coincidence. Guess we will have to wait till the next show that does not work :)

    @ltfearme, do they perhaps allow you to 'set' the language during API searches, because only the 'English' entry is returned on the search. Not sure if it is easy to locate a show that does not have any English info.
     

    ltfearme

    Community Plugin Dev
  • Premium Supporter
  • June 10, 2007
    6,751
    7,196
    Sydney
    Home Country
    Australia Australia
    I think they allow language for search but we default to all so we get them all back.
     

    Users who are viewing this thread

    Similar threads

    Hello, I read some previous posts but I didn't understand if someone did it or worked on it. I'd like to ask you if there will be the chance to interface the MP-TV series plugin with TMDB also. I don't say to eliminate the chance to keep data from TVDB, but at least the option to choose to switch to TMDB or (why not?) other sources.
    Hello, I read some previous posts but I didn't understand if someone did it or worked on it. I'd like to ask you if there will be...
    Hello, I read some previous posts but I didn't understand if someone did it or worked on it. I'd like to ask you if there will be...
    Replies
    0
    Views
    465
    If anyone ever experiences the above, I found a fix. Removing and reinstalling MP-TVSeries fixed it. It must have gotten corrupted during the reinstall of MP. I also had to do the same with TRAKT which had some issues too that were not apparent at the time. All is well once again. :cool:
    If anyone ever experiences the above, I found a fix. Removing and reinstalling MP-TVSeries fixed it. It must have gotten corrupted...
    After much trial and error and comparing this computer with another that was working, I finally found out that Fanarthandler...
    Replies
    1
    Views
    765
    Prerequisites A Spotify account (free or premium) I've not tested with a free account, but according to spotify it should work. Spotify desktop app installed on same computer as you are going to use with MediaPortal Getting ready Create an app at spotify, use this link: Dashboard | Spotify for Developers, you have to login. Click...
    Prerequisites A Spotify account (free or premium) I've not tested with a free account, but according to spotify it should work...
    Prerequisites A Spotify account (free or premium) I've not tested with a free account, but according to spotify it should work...
    Replies
    0
    Views
    1K
    Installing other software, especially MP1, which is partly sharing Tv service with MP2, can make everything worse. Please upload your debug log files, if you want to solve the issue.
    Installing other software, especially MP1, which is partly sharing Tv service with MP2, can make everything worse. Please upload...
    Before you create this bug report: Make sure that your system (Windows, codecs and drivers) is up to date, matching the...
    Replies
    6
    Views
    904
    MP1 MP2 MP2 - V2.4 Problems with series import! DE
    Solution and follow-up in German thread.
    Solution and follow-up in German thread.
    Hi Guys. I'm very frustrated at the moment. Maybe someone can help me! Due to errors importing series at MP 1 (thetvdb only) I...
    Replies
    1
    Views
    1K
    Top Bottom