[Bug] Problem with streaming of recordings (1 Viewer)

josher

New Member
November 29, 2012
3
0
43
Grand Rapids, Michigan
United States of America United States of America
I, also am running into this problem. All other streaming works fine, including LIVETV.

Code:
2012-12-12 22:45:54.38409 [(70)] INFO: Called InitStream with type=Recording; provider=0; itemId=0; offset=0; clientDescription=nexus7; identifier=aMPdroid.-1114558432.ts; idleTimeout=
2012-12-12 22:45:54.38409 [(26)] WARN: Tried to convert a null Recording to WebRecordingBasic
2012-12-12 22:45:54.38409 [(26)] WARN: Failed to load fileinfo for recording
System.NullReferenceException: Object reference not set to an instance of an object.
  at MPExtended.Services.TVAccessService.TVAccessService.GetRecordingFileInfo(Int32 id) in C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.TVAccessService\TVAccessService.cs:line 811
2012-12-12 22:45:54.38409 [(70)] ERROR: Unhandled exception in service (JSON interface)
System.NullReferenceException: Object reference not set to an instance of an object.
  at MPExtended.Libraries.Service.Util.PathUtil.StripFileProtocolPrefix(String path) in C:\Users\Oxan\Documents\Projects\MPExtended\Libraries\MPExtended.Libraries.Service\Util\PathUtil.cs:line 63
  at MPExtended.Services.StreamingService.Code.MediaSource.GetFileInfo() in C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.StreamingService\Code\MediaSource.cs:line 131
  at MPExtended.Services.StreamingService.Code.MediaSource.get_Exists() in C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.StreamingService\Code\MediaSource.cs:line 48
  at MPExtended.Services.StreamingService.Code.Streaming.InitStream(String identifier, String clientDescription, MediaSource source, Int32 timeout) in C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.StreamingService\Code\Streaming.cs:line 148
  at MPExtended.Services.StreamingService.StreamingService.InitStream(WebMediaType type, Nullable`1 provider, String itemId, Nullable`1 offset, String clientDescription, String identifier, Nullable`1 idleTimeout) in C:\Users\Oxan\Documents\Projects\MPExtended\Services\MPExtended.Services.StreamingService\StreamingService.cs:line 220
  at SyncInvokeInitStream(Object , Object[] , Object[] )
  at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
  at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage41(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage4(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage3(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage2(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage1(MessageRpc& rpc)
  at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
 

simonselmer

Portal Pro
December 15, 2008
53
0
Hello
I have same issue also. I can stream everything else but recorded TV. Live TV, MOvies, series, music works. Just not recorded TV.

From the log in MPExtended Config, I see I get same Warning as josher
"Tried to convert a null Recording to WebRecordingBasic"

I am looking very much forward for a update to the issue, because it's an extreme good plugin :)

Super nice work team :)
 

rimmeraj

Portal Member
July 12, 2008
8
0
Hi Diebagger,

awesome app! Just letting you know I also encounter this same issue, and eagerly await the next release to fix it.

thanks
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
M WebMediaPortal Stream LiveTV Problems MPExtended 2
F Problems with new install of MP2 Newcomers Forum 3
A [solved] DiseqC problems after upgrade to 1.25 General Support 9
M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
R Connection (api) problems with thetvdb.com General 3
123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
J Problems with 1.24 StreamedMP 19
Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
404 [solved] EPG problem after Win10 'upgrade' General Support 1
framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
C strange tuner(?) problem TV-Cards 0
R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
T [solved] Startup problem General 6
G Problems with DRR MediaPortal 1 Talk 1
rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
joecrow Default Wide HD Xmas Theme Problem General Support 3
K Sleep mode problem after formating General Support 2
P IPTV Channel Problem TV-Server 0
C Problem playing videos created on IPhone X and Samsung S9 General Support 2
nominefi Problem scanning channels. General Support 0
E Swedish subtitles problem General 2
G Newb trying MP2, trouble with guide data General 5
Top Bottom