Sound stops working after first playback (1 Viewer)

Glith

Portal Pro
April 19, 2006
265
28
Sweden Sweden
Country flag
Do you want me to try something to try and find the problem? Or do we maybe already know why it happens and can do something about it?
My guess is that the new receiver is more intelligent somehow and is expecting an audiostream over the HDMI but somehow the stream is cut completely when Intel is reinitiating the audio during the refresh change after playback. And then the receiver gets confused and stops the output.

I did update the BIOS and also to the latest beta Intel drivers but same result.
 

Sebastiii

Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    Hi :)
    Not sure if I can do anything more :( because here the audio is redetected from MP when removing after DRR but AVR didn't like that :(
    I know that some guys use a HDMI device to keep the connection ON to AVR when such issue happen but not sure if it will work for you.

    You can try something, testing with MPC-HC to play a video and manually change the refresh rate to see how it goes.
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    We can set up as I explain on remote connection if you want, I'm at home right now :p
     

    Glith

    Portal Pro
    April 19, 2006
    265
    28
    Sweden Sweden
    Country flag
    A small workaround I made: Enable skin sound
    When the playback stops and I get no signal I just need to trigger the sound by scrolling or similar -> PCM stream starts and the picture is back

    Maybe an option would be for MP to send an "silent sound" after the playback and DRR switch as a permanent workaround?
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,433
    10,254
    France
    France France
    Country flag
    That's could be an idea, not sure how code that but can look :)
    Are you available for the MPC-HC test ?
     

    Glith

    Portal Pro
    April 19, 2006
    265
    28
    Sweden Sweden
    Country flag
    Regarding our issue with DRR it might have been MPC-HC paused in the background which confused madvr etc. Now it changes refreshrate as it should.
    Sound PCM-stream is still missing(and also picture sometimes) after stop until I trigger a sound by simply triggering a skin sound(up or down in menu).
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    S [solved] No sound - MKV file MediaPortal 1 Talk 2
    A [solved] menu sounds General 1
    R Normalise sound volume somehow? Television (MyTV frontend and TV-Server) 5
    cbr954rr [solved] No sound after clean install? General 24
    Y [solved] Sound will only come out of TV and not computer attached speakers General 1
    T Missing sound in online streaming service (SVTPlay) General Support 3
    rexdog unhandled exception error, and, no sound on first TV channel selected - fine afterwards General 2
    M No sound on videos General 8
    joecrow Loss of Navigation Sounds on Resume from Sleep Mp 1.21 General Support 10
    N [Rejected] Include BBC Sounds (radio catch up) in the Online Videos plugin Feature Requests 4
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    stirlinghart [solved] No Rear Surround Sound inside MP2 General 10
    J amazon plays sound but no video OnlineVideos for MediaPortal 2 0
    H Sound loss & display problems on refresh rate change Watch / Listen Media 21
    R Delay in audio output over HDMI OffTopic 11
    toricred Using TMM, How to Stop Importer From Going to The Movie Database for Data General 1
    mickb [solved] Mediaportal Stops working General Support 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    ajs [solved] 4982: Why this error hard stop when Mediaportal start? MediaPortal 1 3
    rsbrux IR has stopped working Remotes 4
    2BitSculptor MP 1.23.. music stops playing General Support 6
    M MP1 stops responding after Starting Plugins General Support 14
    fredco [solved] Large import not working Moving Pictures 15
    W Recordings will not stop General Support 8
    Similar threads

























    Top Bottom