Test the new API-version | Page 11

Discussion in 'My TVSeries' started by Inker, March 8, 2008.

  1. LXTR

    LXTR Portal Pro

    Joined:
    November 27, 2007
    Messages:
    86
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Spain Spain
    That's my only problem too...


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. z3us
    • Team MediaPortal

    z3us Super Moderator

    Joined:
    December 4, 2007
    Messages:
    1,047
    Likes Received:
    118
    Ratings:
    +123 / 0
    Home Country:
    Spain Spain
    I have that problem too and the one about manually imported episodes not downloading info
     
  4. ltfearme
    • Premium Supporter

    ltfearme Community Plugin Dev

    Joined:
    June 10, 2007
    Messages:
    6,457
    Likes Received:
    4,241
    Gender:
    Male
    Occupation:
    Software Test Engineer
    Location:
    Sydney
    Ratings:
    +5,385 / 0
    Home Country:
    Australia Australia
    Thanks Inker, Looks good for the most part. I tried Updating Guest Stars and Rating for Episode, these updated fine on next import.

    I will do some more testing of different fields e.g. updated thumbnails, overview. As well as test updating of Series Data. I dont think 'Rating' is updating (possibly others) for Series, but will let you know more details later.

    Cheers,
    Damien
     
  5. cool_myll

    cool_myll Portal Member

    Joined:
    April 13, 2007
    Messages:
    44
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Oh its fixed for me in the latest dll
     
  6. LXTR

    LXTR Portal Pro

    Joined:
    November 27, 2007
    Messages:
    86
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Spain Spain
    Yesterday's 298 revision has fixed some season banners for me, but not all of them. Some season banners aren´t still shown
     
  7. Iceken

    Iceken New Member

    Joined:
    October 13, 2007
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Belgium Belgium
    Ok first, I really really love this plugin. Anyone I show this to is absolutely amazed.
    There is one problem that keeps bugging me however :(

    After a full scan, maybe 10% of my actual episodes get imported to the database. The remainder just is missing.
    If I open up the database manually, I have a lot of rows in local_episodes with a negative SeriesID.
    The SeasonIndex & EpisodeIndex column have the right values. I can fix this using some SQL statements,but this is quite inconvenient.

    The weird thing is, it's possible that a couple of episodes for a series get imported correct. Then the remainder gets imported wrong.
    I got the following dir structure:
    ex: Bones\Season 1\Bones - 1x01 - Pilot
    I use the following expression for imports: <series>\Season <season\<series> - <season>x<episode>\<title>

    Anyone who knows why this is happening?
     
  8. z3us
    • Team MediaPortal

    z3us Super Moderator

    Joined:
    December 4, 2007
    Messages:
    1,047
    Likes Received:
    118
    Ratings:
    +123 / 0
    Home Country:
    Spain Spain
    Do a Parsing test and see what episodes are marked in red
     
  9. Iceken

    Iceken New Member

    Joined:
    October 13, 2007
    Messages:
    3
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Belgium Belgium
    It was a long fight, but I finally figured it out.

    First, a parsing test showed everything correct. No episodes were marked red.
    However, as you can see I used the <series> and <season> tags twice.
    So I did a quick run with a modified expression: <series>\Season <season\<series2> - <season2>x<episode>\<title>
    and everything worked.
    Dunno if its bad practice to use the same tag twice, or if it's some weird bug. Everything works again, so I'm happy :)
     
  10. Inker
    • Premium Supporter

    Inker Retired Team Member

    Joined:
    December 6, 2004
    Messages:
    2,055
    Likes Received:
    319
    Ratings:
    +319 / 0
    I have just uploaded 2.0 (pending review). This release is without downloaders, I have however compiled a version including them into SVN (and you can always compile those from there if they remain maintained). It can (always) be found here:
    -
    SourceForge.net Repository - [mp-tvseries] Log of /trunk/MP-TVSeries/bin/ReleaseInclDownloaders/MP-TVSeries.dll

    The only thing new in this build compared to prev. SVN is a little fix for specials inlining and I have enabled jpg for Fanart so you can drop in Fanart from thetvdb.com.

    That's it for me for a while, so have fun.

    Greez
    Inker
     
    • Like Like x 1
  11. Erez

    Erez Portal Pro

    Joined:
    April 10, 2007
    Messages:
    82
    Likes Received:
    9
    Ratings:
    +9 / 0
    Home Country:
    Israel Israel
    I'm having troubles getting episode thumbs to work (latest SVN 2.0).
    If I do a scan from the configuration the thumbnails are downloaded correctly and a reference is added to the database, so if I click on an episode name I can see its thumb (in the configuration view).
    But the moment I enter the plugin screen in Media Portal the references to the episode thumbs disappear and no thumbs are displayed.
    If I set the plugin not to auto update my shares and then enter the plugin screen (after doing a scan from the configuration menu) everything works properly and the the thumbnails are referenced correctly.

    Besides this problem everything works O.K.

    Thanks,
    Erez
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!