Version 0.2.0.1 beta 2 | Page 5

Discussion in 'ASIO music player' started by Symphy, October 18, 2008.

  1. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    It's as mikeyko alread said: over spdif you can only pass unencoded stereo and ac3/dts.
    In order to play ac3/dts over spdif with this plugin, it needs to be encapsulated in 2 channel PCM. Audio ripped from a DVD is in raw format and thus will not play. You can encapsulate it though using the spdifer tool from AC3Filter tools | AC3Filter


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. AberDino
    • Premium Supporter

    AberDino MP Donator

    Joined:
    February 17, 2005
    Messages:
    240
    Likes Received:
    18
    Gender:
    Male
    Location:
    Kincardineshire
    Ratings:
    +24 / 0
    Home Country:
    Scotland Scotland
    Show System Specs
    Symphy, I've long been using your fantastic plugin, but I've got a problem with the more recent versions. I've attached two logs, one with Pureaudio and the other without. All I did was select the genre 'Xmas' and 'add to playlist'. Without Pureaudio, the music starts playing pretty much straight away, but with Pureaudio there is a long delay, during which the system is not responding. This delay can be seen in the log:
    If you need me to do further diagnostics then please let me know.
     
  4. AberDino
    • Premium Supporter

    AberDino MP Donator

    Joined:
    February 17, 2005
    Messages:
    240
    Likes Received:
    18
    Gender:
    Male
    Location:
    Kincardineshire
    Ratings:
    +24 / 0
    Home Country:
    Scotland Scotland
    Show System Specs
    Bump... Symphy, I presume you haven't had a chance to look at this yet?
     
  5. grubi

    grubi Portal Pro

    Joined:
    June 16, 2007
    Messages:
    1,216
    Likes Received:
    77
    Location:
    127.0.0.1
    Ratings:
    +86 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Any idea why version 1.2.2 is the last one giving me bitperfect playback.
    I'm using no ASIO but a soundcard+driver which is capable of playback 44.1 khz without resampling.
    When trying to playback a 44.1 khz DTS file, later versions only give hiss on playback.
    I tried 1.3.0 and all the 2.x releases without success.

    Thanks.
     
  6. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Sorry, i promise to look at it coming week.
     
  7. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Hmm, that's odd. Maybe it's related to changing to floating point samples internally. Will have a look at it coming week.
     
  8. grubi

    grubi Portal Pro

    Joined:
    June 16, 2007
    Messages:
    1,216
    Likes Received:
    77
    Location:
    127.0.0.1
    Ratings:
    +86 / 0
    Home Country:
    Germany Germany
    Show System Specs
    If you need additional information to track down the problem please let me know.

    Thanks
     
  9. trevor

    trevor Portal Pro

    Joined:
    October 17, 2006
    Messages:
    1,600
    Likes Received:
    922
    Gender:
    Male
    Occupation:
    IT Consultant
    Location:
    Chelmsford
    Ratings:
    +951 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    this plugin and LastFm issues.....

    Just want to see if this is just me but I have an issue of LastFM only playing 1 track and then stopping and locking up MP at the same time.

    I pretty sure this was a issue before but jumping the 1st track seemed to solve it...not any more, well not for me.

    I have done some tesing at this happens on 3 seperate installs on MP and this plugin...enable Pure Audio LastFM/MP dies and disable all is fine.

    Pure Audio is a must have for me as have a lot of DTS music and the inbuilt ASIO support stopped worksing ages back!

    I get round it currently by manually disabling the plugin when I want to use Last|FM, in reality this means it is disabled most of the time :)

    If possible a soloution might me to fall back to the internal player of the active module is LastFM.

    Using MP V1.0 / Beta 2 of this plugin / ASIO4ALL V2.8 / Gigabyte MB with Realtec ALC883

    Thanks for any help suggestions

    Trevor
     
  10. MetalKiller

    MetalKiller Portal Member

    Joined:
    October 31, 2008
    Messages:
    21
    Likes Received:
    0
    Ratings:
    +0 / 0
    Hello,
    Sorry but I dont know anything about ASIO, I am wondering:
    - if I am using SPDIF pass thought to my receiver. Is useful to install this ASIO plugin?
    - if you install ASIO4ALL. Is still useful to install Pure Audio plugin?

    Thank you very much in advance ;-)
     
  11. Symphy
    • Premium Supporter

    Symphy Retired Team Member

    Joined:
    August 25, 2007
    Messages:
    495
    Likes Received:
    135
    Gender:
    Male
    Occupation:
    Software Engineer
    Location:
    Groningen
    Ratings:
    +156 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs

    Will look into it.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!