Bug reports for version 2.0.2 (1 Viewer)

Status
Not open for further replies.

Dragy

Portal Pro
April 27, 2009
778
333
28
Netherlands Netherlands
I get a lot of errors when playing media (only Debug errors).
2010-10-01 15:05:33.451171 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
bij IntelligentFrameCorrection.IntelligentFrameCorrection.run(Object sender, DoWorkEventArgs doworkevent)
2010-10-01 15:05:33.451171 [Debug][(24)]: I.F.C.: IntelligentFrameCorrection
2010-10-01 15:05:33.451171 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
bij IntelligentFrameCorrection.IntelligentFrameCorrection.run(Object sender, DoWorkEventArgs doworkevent)
2010-10-01 15:05:33.451171 [Debug][(24)]: I.F.C.: IntelligentFrameCorrection
2010-10-01 15:05:33.451171 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
bij IntelligentFrameCorrection.IntelligentFrameCorrection.run(Object sender, DoWorkEventArgs doworkevent)
2010-10-01 15:05:33.452148 [Debug][(24)]: I.F.C.: IntelligentFrameCorrection
2010-10-01 15:05:33.452148 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
bij IntelligentFrameCorrection.IntelligentFrameCorrection.run(Object sender, DoWorkEventArgs doworkevent)
2010-10-01 15:05:33.452148 [Debug][(24)]: I.F.C.: IntelligentFrameCorrection
2010-10-01 15:05:33.452148 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
bij IntelligentFrameCorrection.IntelligentFrameCorrection.run(Object sender, DoWorkEventArgs doworkevent)
2010-10-01 15:05:33.452148 [Debug][(24)]: I.F.C.: IntelligentFrameCorrection
2010-10-01 15:05:33.453125 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
bij IntelligentFrameCorrection.IntelligentFrameCorrection.run(Object sender, DoWorkEventArgs doworkevent)
2010-10-01 15:05:33.453125 [Debug][(24)]: I.F.C.: IntelligentFrameCorrection
2010-10-01 15:05:33.453125 [Debug][(24)]: I.F.C.: System.NullReferenceException: De objectverwijzing is niet op een exemplaar van een object ingesteld.
My MediaPortal.log is 126MB because of this :p (and CPU usage is terrible high in debug mode because of this)
 

Marvman

Retired Team Member
  • Premium Supporter
  • November 14, 2007
    1,163
    735
    Bavaria
    Germany Germany
    why I'm asking for bugs :D

    Hi Dragy,

    can you delete your log, and play the media for some seconds, stop it and attach your log, that NullPointerException is odd, and I never had one with the 2.0.2 version.
     

    Dragy

    Portal Pro
    April 27, 2009
    778
    333
    28
    Netherlands Netherlands
    I reinstalled the plugin and now I don't get that error anymore..
    When watching HD content and IFC is active, CPU goes to 50%. I'm sure it's IFC because normall MediaPortal.exe CPU is 7% and every 8 seconds it's around 50%!
    Are my settings for IFC unfavorable?

    Else I have to deactivate it :(

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <profile>
      <section name="Config">
        <entry name="4:3">no</entry>
        <entry name="16:9">yes</entry>
        <entry name="21:9">no</entry>
        <entry name="scaninterval">7000</entry>
        <entry name="stop counter">8</entry>
        <entry name="verboselogging">no</entry>
        <entry name="correct AR">yes</entry>
        <entry name="isBlackBarScannerEnabled">yes</entry>
        <entry name="maxBrightnessTreshold">35</entry>
        <entry name="minBrightnessTreshold">10</entry>
        <entry name="auto start">yes</entry>
        <entry name="stabilizer">10</entry>
        <entry name="single black bar height">70</entry>
        <entry name="double black bar height">180</entry>
        <entry name="HD support">yes</entry>
        <entry name="HD height">600</entry>
        <entry name="HD width">1200</entry>
        <entry name="HD operator">or</entry>
        <entry name="video support">no</entry>
        <entry name="stabilization factor">10</entry>
        <entry name="stabilization tolerance">7</entry>
        <entry name="edge detection tolerance">4</entry>
        <entry name="use only zoom factor">no</entry>
      </section>
      <section name="Top Scan Area">
        <entry name="height">25</entry>
        <entry name="width">30</entry>
        <entry name="y">0</entry>
        <entry name="x">33</entry>
      </section>
      <section name="Bottom Scan Area">
        <entry name="height">25</entry>
        <entry name="width">30</entry>
        <entry name="y">75</entry>
        <entry name="x">33</entry>
      </section>
      <section name="Left Scan Area">
        <entry name="height">30</entry>
        <entry name="width">20</entry>
        <entry name="y">30</entry>
        <entry name="x">0</entry>
      </section>
      <section name="Right Scan Area">
        <entry name="height">30</entry>
        <entry name="width">20</entry>
        <entry name="y">30</entry>
        <entry name="x">80</entry>
      </section>
      <section name="Video Crop">
        <entry name="top">0</entry>
        <entry name="bottom">0</entry>
        <entry name="left">0</entry>
        <entry name="right">0</entry>
      </section>
      <section name="Overscan Crop">
        <entry name="top">3</entry>
        <entry name="bottom">3</entry>
        <entry name="left">3</entry>
        <entry name="right">3</entry>
      </section>
      <section name="View Mode">
        <entry name="4:3">NonLinearStretch,0,0,0,0</entry>
        <entry name="4:3 Letterbox">Stretch,0,0,0,0</entry>
        <entry name="16:9">Stretch,0,0,0,0</entry>
        <entry name="16:9 Letterbox">Stretch,0,0,0,0</entry>
        <entry name="16:9 with Sidebars">NonLinearStretch,0,0,0,0</entry>
        <entry name="21:9">Normal,0,0,0,0</entry>
        <entry name="Default">Stretch,0,0,0,0</entry>
      </section>
    </profile>
     

    hirscho

    Portal Pro
    December 24, 2006
    186
    20
    Germany Germany
    Hi guys with frame drops or CPU spikes,

    I implemented a resize method (based on gemx's patch) to capture a smaller frame from the GPU.

    Please test and tell me if it works or not.

    Latest version based on MP 1.1 can be found here

    Replace all files and play around with the slider I added to the config.
    For the people without frame drops/spikes put the slider to 100%.

    Hi Marvman

    Are you planning to release a patch for MP 1.1.1? I missed the opportunity to test under MP 1.1.


    Oliver
     

    pacoma

    Portal Pro
    March 22, 2005
    404
    25
    48
    Wil
    Switzerland Switzerland
    AW: Intelligent Frame Correction 2.0 *BEAST UNLEASHED*

    Hello Everybody

    search help about I.F.C. and m2ts files.....


    I have so many m2ts files on my Storage, but there is not gone with m2ts. All the other Files (avi, mkv, vob, mpg...) are gone.....

    Sometimes the Blackbar is on somethimes off

    Is this a bug ore something other my error???
     

    Marvman

    Retired Team Member
  • Premium Supporter
  • November 14, 2007
    1,163
    735
    Bavaria
    Germany Germany
    I reinstalled the plugin and now I don't get that error anymore..
    When watching HD content and IFC is active, CPU goes to 50%. I'm sure it's IFC because normall MediaPortal.exe CPU is 7% and every 8 seconds it's around 50%!
    Are my settings for IFC unfavorable?

    Else I have to deactivate it :(
    Your settings are OK. I'll provide a patched beta for MP 1.1.1 with a resize option, hope this resolves your CPU spikes.
    Do you determine stuttering with HD stuff?

    Hello Everybody

    search help about I.F.C. and m2ts files.....


    I have so many m2ts files on my Storage, but there is not gone with m2ts. All the other Files (avi, mkv, vob, mpg...) are gone.....

    Sometimes the Blackbar is on somethimes off

    Is this a bug ore something other my error???
    No clue what do you mean or what do you want to say.

    Clear your logs, play your m2ts and send me you logs, maybe then I can decrypt you message :)

    Btw.: do you play the m2ts file with the MediaPortal internal player or do you use an external player?
     

    pacoma

    Portal Pro
    March 22, 2005
    404
    25
    48
    Wil
    Switzerland Switzerland
    AW: Re: Bug reports for version 2.0.2

    I reinstalled the plugin and now I don't get that error anymore..
    When watching HD content and IFC is active, CPU goes to 50%. I'm sure it's IFC because normall MediaPortal.exe CPU is 7% and every 8 seconds it's around 50%!
    Are my settings for IFC unfavorable?

    Else I have to deactivate it :(
    Your settings are OK. I'll provide a patched beta for MP 1.1.1 with a resize option, hope this resolves your CPU spikes.
    Do you determine stuttering with HD stuff?

    Hello Everybody

    search help about I.F.C. and m2ts files.....


    I have so many m2ts files on my Storage, but there is not gone with m2ts. All the other Files (avi, mkv, vob, mpg...) are gone.....

    Sometimes the Blackbar is on somethimes off

    Is this a bug ore something other my error???
    No clue what do you mean or what do you want to say.

    Clear your logs, play your m2ts and send me you logs, maybe then I can decrypt you message :)

    Btw.: do you play the m2ts file with the MediaPortal internal player or do you use an external player?
    Please excuse my previous false post office.

    My problem is that I stored many films in the format .m2ts on my HTPC, for which the black bar above and down is visible. (see log Mediaportal.xml)

    With other formats (.avi, .mkv…) become in accordance with my attitudes in the I.F.C. - Plugin changed. (see attitudes IFC.xml)
     

    Attachments

    Marvman

    Retired Team Member
  • Premium Supporter
  • November 14, 2007
    1,163
    735
    Bavaria
    Germany Germany
    Re: AW: Re: Bug reports for version 2.0.2

    I reinstalled the plugin and now I don't get that error anymore..
    When watching HD content and IFC is active, CPU goes to 50%. I'm sure it's IFC because normall MediaPortal.exe CPU is 7% and every 8 seconds it's around 50%!
    Are my settings for IFC unfavorable?

    Else I have to deactivate it :(
    Your settings are OK. I'll provide a patched beta for MP 1.1.1 with a resize option, hope this resolves your CPU spikes.
    Do you determine stuttering with HD stuff?

    Hello Everybody

    search help about I.F.C. and m2ts files.....


    I have so many m2ts files on my Storage, but there is not gone with m2ts. All the other Files (avi, mkv, vob, mpg...) are gone.....

    Sometimes the Blackbar is on somethimes off

    Is this a bug ore something other my error???
    No clue what do you mean or what do you want to say.

    Clear your logs, play your m2ts and send me you logs, maybe then I can decrypt you message :)

    Btw.: do you play the m2ts file with the MediaPortal internal player or do you use an external player?
    Please excuse my previous false post office.

    My problem is that I stored many films in the format .m2ts on my HTPC, for which the black bar above and down is visible. (see log Mediaportal.xml)

    With other formats (.avi, .mkv…) become in accordance with my attitudes in the I.F.C. - Plugin changed. (see attitudes IFC.xml)
    OK, here we go again.

    You played the Prestige, which is in a 16:9 format. So basically no correction is necessary. You movie have black bars though. That means The movie was originally a 21:9 movie, which is now embedded into a 16:9 format (black bars top and bottom were added). If you don't like black bars at all, you have the following options.


    • Disable "correct AR", but then you have banana heads (movie is vertical stretched).

    • Set an "Advanced View Mode", under 16:9 Letterbox set a 12% or 13% zoom mode for top, bottom, left and right. You will lost some content left and right, so its up to you.
    What I can say to you, IFC works correct.
     

    pacoma

    Portal Pro
    March 22, 2005
    404
    25
    48
    Wil
    Switzerland Switzerland
    AW: Re: AW: Re: Bug reports for version 2.0.2

    Your settings are OK. I'll provide a patched beta for MP 1.1.1 with a resize option, hope this resolves your CPU spikes.
    Do you determine stuttering with HD stuff?



    No clue what do you mean or what do you want to say.

    Clear your logs, play your m2ts and send me you logs, maybe then I can decrypt you message :)

    Btw.: do you play the m2ts file with the MediaPortal internal player or do you use an external player?
    Please excuse my previous false post office.

    My problem is that I stored many films in the format .m2ts on my HTPC, for which the black bar above and down is visible. (see log Mediaportal.xml)

    With other formats (.avi, .mkv…) become in accordance with my attitudes in the I.F.C. - Plugin changed. (see attitudes IFC.xml)
    OK, here we go again.

    You played the Prestige, which is in a 16:9 format. So basically no correction is necessary. You movie have black bars though. That means The movie was originally a 21:9 movie, which is now embedded into a 16:9 format (black bars top and bottom were added). If you don't like black bars at all, you have the following options.


    • Disable "correct AR", but then you have banana heads (movie is vertical stretched).

    • Set an "Advanced View Mode", under 16:9 Letterbox set a 12% or 13% zoom mode for top, bottom, left and right. You will lost some content left and right, so its up to you.
    What I can say to you, IFC works correct.
    also with the attitude of you no change

    if I change the 16:9 original then functions it, but all original 16:9 are then too largely.

    i think my m2ts files are 16:9 inc. the blackbars (Top & Bottom), and IFC change nothing because for IFC ist 16:9
     
    Status
    Not open for further replies.

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
    ge2301 Bugs and Improvements Nereus 0
    N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
    Scheibes [solved] Kategorisierung der Genres (Bug?) Allgemeines Support- und Diskussionsforum 13
    joecrow 3 Bugs in MP 1.21 1.21 5
    dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
    rsbrux Various bugs, some Zombies ;-) 1.20 6
    J [solved] Mp 2.2 future bugs General 7
    S [MP2-768] Installation Setup Failed - Error 0x80070666 - VC++ 2015/2017 Redist bug 2.2 Archive 19
    D MP2.2: Possible bugs 2.2 Archive 20
    R Jira bug exposed private server keys at major companies Developer Discussions 1
    R Minor bug in recorded TV list Watch / Listen Media 0
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    V [solved] FTA channels but reported as encrypted MediaPortal 1 Talk 7
    W [solved] Incorrect audio being reported Moving Pictures 4
    Rob Hexenmeister [solved] Latest media handler - time reported as date Fanart Handler 18
    D Recorded TV: Wrong running time being reported General 3
    M MPExtended reports "An unexpected error occurred" WebService and Mobile Access 5
    J Short User Report - trying MP2 General 3
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    caveman [solved] Cannot download new version My TVSeries 5
    ajs [Help Us!] MP1 X64 Version MediaPortal 1 20
    RoChess Splashscreen MePo version Titan Skin Feedback 8
    D how to disengage from one version of a plugin to use another Newcomers Forum 0
    Top Bottom