[solved] Couldn't show chinese in the skin? (1 Viewer)

meinu

Portal Member
January 11, 2016
6
2
51
China China
when i open MediaPortal2,it couldn't show chinese in the skin,but can show english,how can i do?[DOUBLEPOST=1452490930][/DOUBLEPOST]all the chinese in the skin couldn't show.by the way i use win 10 chinese version.
 

Attachments

Last edited:

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,391
    6,966
    Germany Germany
    Country flag
    Character support depends on the used font inside the Skin. Unfortunately I don't know any font which covers all unicode letters (cyrillic, hebrew, chinese...)

    If you like you might try to change the default font of the skin. There are 2 things you would have to do:
    The links above do only point to the source codes, on your local installation you find them here: C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\Titanium\Skin\Titanium\fonts

    Let me know if you need further help, I'm curious about screenshots in chinese :)
     

    meinu

    Portal Member
    January 11, 2016
    6
    2
    51
    China China
    thanks morpheus_xx.i modified these two files ,then reboot my pc,but still couldn't show chinese.
     

    meinu

    Portal Member
    January 11, 2016
    6
    2
    51
    China China
    thanks Vasilich.
    My fonts folder screenshot[DOUBLEPOST=1452560107][/DOUBLEPOST]default-font.xml screenshot[DOUBLEPOST=1452560143][/DOUBLEPOST]Arial.desc screenshot[DOUBLEPOST=1452560210][/DOUBLEPOST]ArialBold.desc screenshot
     

    Attachments

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    Ok. I see that arial is used as skin font. But arial doesn't have chinese chars. You should use "Arial Unicode MS" with font file "ARIALUNI.TTF" - pls check first if it is installed on your PC (it is installed on all my PCs with Windows 7, but it can come with MS Office, so - not sure). Or you can use any other font that supports chinese symbols.
     

    meinu

    Portal Member
    January 11, 2016
    6
    2
    51
    China China
    @Vasilich thank you very much.Problem solved!:LOL:
    by the way,is there a way to translate the interface of MediaPortal 2 TV Configuration to chinese?
     

    Attachments

    Last edited:

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    toricred Only Show Actual Recordings General 1
    R MP 2.2.3 Search TV program only with the correct begin of show title General 7
    F Show Player info while skipping Feature Requests 0
    P Recordings not showing up unless re-imported and not possible to delete General 0
    C Imported media doesn't show up immediately? General 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    tano_grasa Movie cover not showing when starting a movie aMPed 0
    M [Rejected] Always show full hours in TV Guide Feature Requests 2
    J Understanding what EPG shows about schedules General 8
    J Show media item location Feature Requests 4
    ratata Non present codecs is still showing... MediaPortal 1 Talk 2
    C Recording back to back shows from IPTV streams General Support 8
    J Resume from Standby Last Module TV Showing TV Server Settings Television (MyTV frontend and TV-Server) 2
    K Genres in MovingPictures not show ... Fanart Handler 12
    G How best to get cover art for tracks to show up on the Audio Menu (Latest Added, Unplayed)? General 9
    Lehmden Manual schedule: Possibility to enter a show name Feature Requests 1
    N [Finished] [MP2-806] Playing a recorded radio program does not show screen to allow skipping forward, etc MediaPortal 2 141
    B Media info shows audio is 5.1 MP shows 2.0 Watch / Listen Media 2
    ge2301 [Finished] [MP2-782] Show mouse cursor only if it was moved more than 10 pixels MediaPortal 2 13
    stirlinghart Folders showing up in MOVIES share General 2
    W [solved] MP 1.20 Video IMDB no showing plot General Support 129
    F Config starting, but not showing. Moving Pictures 2
    W Strange recording behavior - Schedule shows type once when should be always General Support 1
    M partially watched video/song/recorded tv show file text color + remember cursor in folders other features (of release or svn versions) 28
    N [solved] MediaPortal do not show TV Channels, although Channels found in TV-Server Configuration Television (MyTV frontend and TV-Server) 7
    Similar threads

























    Top Bottom