LiveTV freezes and shows a lot of artifacts | Page 3

Discussion in '1.5.x' started by Snoopy87, March 31, 2013.

  1. driver140771
    • Premium Supporter

    driver140771 MP Donator

    Joined:
    February 8, 2010
    Messages:
    474
    Likes Received:
    39
    Gender:
    Male
    Location:
    Unterfranken
    Ratings:
    +51 / 3
    Home Country:
    Germany Germany
    Show System Specs
    In the file from Post #18 the picture have artefacts for 1sec.
    In the file from Post #17 the picture stopps.[DOUBLEPOST=1364923710][/DOUBLEPOST]On the other client with the original TsReader.ax (MP 1.3.0) there is the same problem.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    It looks like the video decoder is sometimes just hanging after stream errors - see below for things to try:

    As this is H.264, it may be the AMD hardware decoder which having the problem (assuming you are using DXVA) - have you tried software-only decoding in LAV ?
     
    Last edited: April 2, 2013
  4. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    Hi,

    attached you will find the log while I played the recorded file which includes the artifacts.

    Best regards
    Sascha
     
  5. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    The TsReader log is full of 'PES 0-0-1 fail' errors - these are usually caused by de-cryption problems. I can't tell you anything else from the logs - it's finding good packets sometimes, but then after a few seconds it's getting bad data again.

    Your problem is different to driver140771's problem.
     
    Last edited: April 2, 2013
  6. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    If you change the file extension on that recording from .ts to .mts and play the file using the Video player (which should use LAV splitter), does it play correctly ?
     
  7. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Hi Sascha,

    Please replace TsReader.ax with the attached version, play the same recording again and attach the log - it has extra logging so I can work out the reason for the 'PES 0-0-1 fail' messages.
     

    Attached Files:

  8. naich
    • Premium Supporter

    naich MP Donator

    Joined:
    August 6, 2007
    Messages:
    529
    Likes Received:
    25
    Ratings:
    +25 / 0
    Home Country:
    Germany Germany
    Show System Specs
    I also had Problems with artefacts, i use 1.3.0 Final and didn't have those problems bevor.

    Now i 've disabled the xbmc TV Server Plugin (newest one) and the problem is gone!

    Maybe someone with These problems (also using the xbmc server Plugin) give it a try!

    Cu
     
  9. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    It's much better, but not completly artifact-free (90% of the artifacts are gone and there a of course audio interruptions)

    With your debug version of TSReader it seems to be a litte bit worse than with nostopmod70. Attached you will find the log.

    Thanks for helping us! :)
     
    Last edited: April 3, 2013
  10. Owlsroost
    • Team MediaPortal

    Owlsroost Development Group

    Joined:
    October 28, 2008
    Messages:
    5,537
    Likes Received:
    2,829
    Location:
    Cambridge
    Ratings:
    +4,131 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    It looks like parts of the file are encrypted/corrupted (as I suspected) - the PES header data is junk (hence the PES 0-0-1 fail messages).

    The fact you get picture corruptions/audio dropouts using LAV splitter means the .ts has errors/junk/encrypted data sections, but I *might* be able to improve TsReader.ax handling of the bad sections.

    Could you upload a short (1- 2 minutes) section from the start of the .ts file - use a file splitter utility etc (not a video editor) to create the short file so it's not modified at all. FTP details below (or use Dropbox etc - anywhere as long as I can download it)

    Public upload FTP account

    Address: 78.47.34.246
    Login: tsdump@team-mediaportal.com
    Password: mpuser88
     
    Last edited: April 4, 2013
  11. Snoopy87

    Snoopy87 Portal Pro

    Joined:
    August 12, 2012
    Messages:
    468
    Likes Received:
    123
    Gender:
    Male
    Ratings:
    +166 / 10
    Home Country:
    Germany Germany
    Show System Specs
    I'll upload the file in the next 1-2 hours.

    The whole recording is less than a minute (because I just recorded the issue to log it). The file size is ca. 50 MB. So should I upload the whole file? (as a ZIP-file)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!