LiveTV freezes and shows a lot of artifacts (1 Viewer)

Owlsroost

Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    I'll upload the file in the next 1-2 hours.

    The whole recording is less than a minute (because I just recorded the issue to log it). The file size is ca. 50 MB. So should I upload the whole file? (as a ZIP-file)
    Yes, thats OK
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Attached is a new TsReader.ax - I've added a new registry key in 'HKEY_CURRENT_USER\Software\Team MediaPortal\TsReader' called 'DisablePESFailFlush' - set this to '1' and it will disable some of the error recovery features. (Just play something first to get the key created)

    Note - the sample video file is corrupted (presumably due to de-cryption failures) - TsReader (or anything else) cannot fix that, this mod is just to try and make it recover faster/cleaner when this happens.
     

    Attachments

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    Thanks!

    With your TSReader I can't watch TV anymore. While starting the TV plugin, MediaPortal freezes a few minutes and then it shows the message "an unknown error occured".
     

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    Try different browser or pc. I tried all my PC and the attachment works ;-)
     

    Owlsroost

    Development Group
  • Team MediaPortal
  • October 28, 2008
    5,540
    5,038
    Cambridge
    United Kingdom United Kingdom
    Country flag
    Thanks!

    With your TSReader I can't watch TV anymore. While starting the TV plugin, MediaPortal freezes a few minutes and then it shows the message "an unknown error occured".
    I've just tried live TV and it works fine for me (using UNC paths and RTSP) - also there is no TsReader.log in your zip file so it looks like it hasn't even got as far as trying to load it (and there are no error messages in the MP logs).

    There are errors in the TV server logs, so I suspect there is/was a problem with your TV server.....(and there is no TsWriter log)

    (There have been 8 downloads of the TsReader zip file so far - anyone else tried it ?)
     
    Last edited:

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    Strange... I tried it a few times incl. restarting my HTPC. And now itsuddenly worked :-D I will test your version and let you know if I see any difference within the next couple of days.
     

    HomeY

    Test Group
  • Team MediaPortal
  • February 23, 2008
    6,466
    4,634
    45
    ::1
    Netherlands Netherlands
    Country flag
    (There have been 8 downloads of the TsReader zip file so far - anyone else tried it ?)
    I gave it a try and so far it seems good. Looks like i even got rid of some PES errors in my logs.
     

    Snoopy87

    Portal Pro
    August 12, 2012
    468
    167
    Germany Germany
    I still have problems with the new TSReader. It worked only one time. After restarting my HTPC I got the "unkown error" and TV was not working. This only happens with the new TSReader, so it's related to the new version. If I use the old TSReader there is never any problem. So I can't test your new TSReader :-(

    Also, the few hours your TSReader worked: I still got the artifacts. I don't know if it's got better or not, because currently I don't have so many artifacts. It's very strange. Sometimes it's very heavy, sometimes I can watch a few hours without artifacts.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    1gkar [solved] LiveTV Records Causing 100% Drive Activity Television (MyTV frontend and TV-Server) 10
    rbo Mp 1.21 pre - probleme livetv und videos Allgemeines Supportforum 5
    M WebMediaPortal Stream LiveTV Problems MPExtended 2
    framug General TV Engine, go ahead or continue freeze ? TV Engine 1
    404 [solved] Live TV...video and audio freeze General Support 20
    R [further infos missing] some movies freezing evry seconds Submit: Bug Reports 9
    S Mediaportal 1.22 Pre-Release remote live-tv freezes MediaPortal 1.22 Pre Release 0
    T Problems re-installing after MP 1.21.0 freeze up! Installation, configuration support 2
    joecrow Win 10 crash, hang and freeze with USB Tuner. General Support 13
    L MP Playback Freezes When Unpausing from Minimized Screen General Support 6
    R [solved] MTS files freeze on last frame Watch / Listen Media 2
    HTPCSourcer Harmony Smart Control freezes Input/Output Interfaces 3
    J Freezing after some time running General Support 21
    Remoteglen Freezing on startup General Support 4
    HTPCSourcer MP2 - V2.1 Picture freeze when jumping forward Older releases 7
    M EPG color by length of TV-show MediaPortal 1 Talk 1
    toricred Only Show Actual Recordings General 1
    R MP 2.2.3 Search TV program only with the correct begin of show title General 7
    F Show Player info while skipping Feature Requests 0
    P Recordings not showing up unless re-imported and not possible to delete General 0
    C Imported media doesn't show up immediately? General 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    tano_grasa Movie cover not showing when starting a movie aMPed 0
    M [Rejected] Always show full hours in TV Guide Feature Requests 2
    J Understanding what EPG shows about schedules General 8
    Similar threads

























    Top Bottom