My Films 6.0 final released ! (16.12.2012) - V6.0.3.2921 (MP 1.3 & 1.4) (2 Viewers)

Which Movie Catalog do you use with My Films 6?


  • Total voters
    76

Iceman89610

Portal Pro
July 19, 2008
379
28
Ipswich
Home Country
United Kingdom United Kingdom
Great work guys. Still requires the following (I think)......

1. Option to use own folder.jpg and backdrop.jpg if theses files are present within the movie folder. If not, use downloaded graphics.
2. Automatic sorting and grouping (such as IMDB+).

Other than that, great as far as I can see.

Stephen
 

Dadeo

Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    Thanks @Iceman89610!
    1. You can use folder.jpg - see Picture Handling in AMCU settings, or you can use it with NFO grabber (selectable in Setup Wizard now) I will try to make that a bit more 'obvious' in the wiki ;)
    2. You can also use fanart in your movie folder using NFO grabber script - see Fanart Handling in AMCU settings - especially 'use Script for Fanart' (e.g. NFO grabber) - although I would appreciate if you would add that to the tracker because imo it is not exactly what you want yet. Also, I think users name fanart in their movie folder in many different ways, so that has to be considered as well.
    3. Automatic sorting and grouping - You can also do this in several ways - you don't need an add on - see Box Sets, Series, Groups - best of all in My Films you can even create or change Groups in the GUI!
    If those features don't meet your needs, please provide a bit more detail what you wish to achieve and we'll see what can be done. Thanks!
     
    Last edited:

    doveman

    Portal Pro
    February 12, 2008
    2,326
    178
    Home Country
    United Kingdom United Kingdom
    Country flag
    Nice job (y)

    From a quick look, it seems that you've eliminated those nasty double negatives and the Wiki's a lot clearer about the Import Modes now. :)
     

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    Thanks doveman - an early Christmas present for you :p Guzzi and I spent the last two days working it out to squeeze it in 6.0.1 final! As you will see in the Issue Tracker, we still want to move the 'Import Behaviour in My Films' setting to My Films setup (where it really belongs!), and add the option in GUI > Global settings as well, but that was a bit more risky change :eek: and we did not want to delay release. So we'll try to do that for 6.0.2 or 6.1.

    The worst part was finding and editing 20+ pages in wiki where it was mentioned :cry:
     
    Last edited:

    doveman

    Portal Pro
    February 12, 2008
    2,326
    178
    Home Country
    United Kingdom United Kingdom
    Country flag
    Well I do appreciate my early Christmas present from Guzzi and yourself. No longer will I go half-mad trying to work out what the settings do :p

    I dare say you need a well-deserved lie-down after all that though :sleep:

    Definitely the right call to not try and fix everything at once though. Always best to leave major/risky changes until everything's settled down a bit and Christmas isn't rapidly approaching as no-one wants to be faced with loads of "help!" messages if something doesn't work as it should at that time of year.

    Hell, I was talking about my brother's PC I was building for him last Christmas and I still haven't got it done :oops: I nearly managed it for his birthday in September until the motherboard died on me and I lost the will to live :cry: but I'm sure I'll get it done one day, hopefully before his clapped out P3 completely dies on him!
     

    Dadeo

    Docs Group Manager
  • Premium Supporter
  • November 26, 2006
    5,340
    3,321
    Himalayas, India
    Home Country
    Canada Canada
    Thanks doveman - yes we want to focus on solving any issues that arise in My Films 6 over the next month or so, especially as users 'grow into' using all the new features. I think we caught most of them during the beta and all the testing our testers did! But you know how it is ;) - hard to catch every possible issue especially when My Films supports so many different use cases and setups (just like MP does!)

    Of course there may also be changes with MP 1.3.0 beta soon to be released - at least skin changes to support the new Default skin and the great new skin features beta supports. And everyone will be busy playing with beta anyways. ;)

    I think you should wait till your brother's P3 craps out - I don't think it even meets the hardware requirements for MP! :p Then you can tell him it was a planned strategy, not your tardiness ;) Better yet, buy him something for Christmas (and save yourself the time) - the money will be worth it! LOL
     

    z3us

    Portal Pro
    December 4, 2007
    1,047
    123
    42
    Home Country
    Spain Spain
    Do you think that the "enable trakt" checkbox is necessary? It´s redundant, because in the trakt config there is already a checkbox for myfilms.
     

    Guzzi

    Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    • Thread starter
    • Moderator
    • #9
    Do you think that the "enable trakt" checkbox is necessary? It´s redundant, because in the trakt config there is already a checkbox for myfilms.
    Hi, yes, this is needed, because: If users do have multiple configs, they can enable and disable the trakt support PER config.
    Example:
    config A: movies (trakt enabled)
    config B: documentation (trakt disabled)
    config C: private movies (trakt disabled)
    For single config users, it is of course a "redundant" setting, yes...
     

    Guzzi

    Retired Team Member
  • Premium Supporter
  • August 20, 2007
    2,161
    747
    Country flag
    • Thread starter
    • Moderator
    • #10
    My Films 6.0.2 maintenance release
    (supports MediaPortal 1.2.x and 1.3 beta)

    Update available, mainly fixing issues reported so far.

    ChangeLog for V6.0.2:

    Features:
    - Add new property to show info about related context
    - Move 'Import if no auto match' setting from AMCU to MF Setup and add to MF GUI options
    - Allow edition of previously created filter expressions for views

    Fixes:
    - With multi part movies a "watched" event is send after each part
    - person role should be removed from label2 in related persons view
    - Internal IMDB person info grabber stopped working due to IMDB changes
    - Random Fanart does not display when Reverse Person Names is enabled
    - Some Person Image Files being saved in wrong directory
    - Bluray from folder do not natively play with MP1.3alpha
    - '&' not correctly displayed in Movie Titles and cover does not display in facade
    - Rework of internal dialog handling
    - navigation engine does have inconsistant behaviour for start settings
    - Custom Movie Group Settings are not applied in GUI and Layout is not saved.
    - Back navigation sets visibility condition too late
    - MP language is not properly detected and used
    - View Options context menu options do not work correctly for Group lists
    - Download Person Images (selected film) displays on Main window context menu under Updates
    - Grabber Interface - Detail tab : "Genre" should be "Category"

    Download via Repo or MPE installer.

    Have fun,

    Guzzi
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    WinTV v10 TV server may have the tv cards locked.
    WinTV v10 TV server may have the tv cards locked.
    I recently tried to test the MP 1.29 Pre-release, to find out the MySQL Server 5.6 won't install & connect host to my TV Tuner...
    Replies
    2
    Views
    250
    found the cause of high cpu utilization in interrupts, after resuming from ACPI S3 sleep state, to be the WOL be enabled on Realtek ethernet adapter. i updated the Realtek drivers to latest but made no change, have disabled WOL, and issue now resolved....
    found the cause of high cpu utilization in interrupts, after resuming from ACPI S3 sleep state, to be the WOL be enabled on Realtek...
    Hello MP team, I've been using MP since 1.21. I recently updated my Windows 7 system to MP final 1.24, and am experiencing a new...
    Replies
    4
    Views
    1K
    Ok thanks guys I will get onto my media pc and check it again and get some logs But the Bathurst car race is on and thats all i am focused on at the moment. Thanks again.
    Ok thanks guys I will get onto my media pc and check it again and get some logs But the Bathurst car race is on and thats all i am...
    Hi I have never used My Films before, but after finding it I think it would be just what I need as I use Media Center Master. I am...
    Replies
    5
    Views
    4K
    Great thanks :)
    Great thanks :)
    We've just finished the final 1.18.0 release of MediaPortal 1. Highlights of this release Bugfixes: We fixed some issues with...
    Replies
    1
    Views
    13K
    • Locked
    Hello, the MP2 team is glad to announce that the final version of MediaPortal 2.1 has just been released. :) Please see the release news for details and download information: English Deutsch As always: please do not post support requests and bug reports in this thread but use the appropriate sections as explained in the news.
    Hello, the MP2 team is glad to announce that the final version of MediaPortal 2.1 has just been released. :) Please see the...
    Hello, the MP2 team is glad to announce that the final version of MediaPortal 2.1 has just been released. :) Please see the...
    Replies
    0
    Views
    2K
    Top Bottom