No Bluray playback......can't play index....logs included (1 Viewer)

tonewheelkev

Portal Pro
February 10, 2012
402
41
Leeds
Home Country
United Kingdom United Kingdom
TBH....I've never had this bit working.
After reading a bit....I have uninstalled BD handler plugin...but to no avail.

Any observations please?

Thanks
 

mm1352000

Retired Team Member
  • Premium Supporter
  • September 1, 2008
    21,577
    8,224
    Home Country
    New Zealand New Zealand
    Any observations please?
    Your config shows that you've disabled the internal BD player without configuring an external player:
    Code:
    <section name="bdplayer">
        <entry name="useforbluray">no</entry>
        <entry name="useInternalBDPlayer">no</entry>

    That ain't ever gonna work!

    I suggest you amend this by ticking "use internal Blu-Ray menu player" and unticking "use external player for Blu-rays (replaces internal player)":
    Blu-ray - MediaPortal 1 - MediaPortal Wiki
     

    tonewheelkev

    Portal Pro
    February 10, 2012
    402
    41
    Leeds
    Home Country
    United Kingdom United Kingdom
    That's odd....neither boxes were ticked!
    OK....so ticked 'use internal player'.....still doesn't work....:(
    Log attached!

    Thanks
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,583
    10,403
    France
    Home Country
    France France
    Hi,

    It seems somehow, that filter are not working or not register (the installer should do that for you):
    [2017-05-08 11:21:00,371] [Error ] [MPMain ] [ERROR] - BDPlayer: Exception while creating DShow graph An object or name was not found.

    You can try to manually register it by open a command prompt with admin right and do the following :
    cd C:\Program Files (x86)\Team MediaPortal\MediaPortal
    regsvr32 BDReader.ax

    Then you should have this :
    upload_2017-5-8_12-38-21.png


    If it failed then something is wrong with the installation and maybe it's missing VS2015 Redist C++. and then surely other filter failed to be registered.
     

    tonewheelkev

    Portal Pro
    February 10, 2012
    402
    41
    Leeds
    Home Country
    United Kingdom United Kingdom
    Hi,

    It seems somehow, that filter are not working or not register (the installer should do that for you):
    [2017-05-08 11:21:00,371] [Error ] [MPMain ] [ERROR] - BDPlayer: Exception while creating DShow graph An object or name was not found.

    You can try to manually register it by open a command prompt with admin right and do the following :
    cd C:\Program Files (x86)\Team MediaPortal\MediaPortal
    regsvr32 BDReader.ax

    Then you should have this :
    View attachment 189848
    .

    Thanks Sebastiii.....got that....did it....still won't play!!!
     

    Sebastiii

    Development Group
  • Team MediaPortal
  • November 12, 2007
    16,583
    10,403
    France
    Home Country
    France France
    Are you sure that all codecs are OK ?
    upload_2017-5-8_13-52-11.png

    When clicking on screwdriver you should get the settings :
    upload_2017-5-8_13-52-47.png


    upload_2017-5-8_13-53-1.png


    Check also all format for audio, maybe something is wrongly setup :)
     

    mm1352000

    Retired Team Member
  • Premium Supporter
  • September 1, 2008
    21,577
    8,224
    Home Country
    New Zealand New Zealand
    @tonewheelkev
    You're trying to play a commercial Blu-Ray which includes encryption/copy-protection without any ability to decrypt/un-protect it:
    08-05-2017 11:21:00.367 [ 9ac]CLibBlurayWrapper - Disk is encrypted, no decryption is currently supported

    Won't work. All this stuff is explained in the manual (wiki)! ;)
    Blu-ray - DVD Discs - Images - MediaPortal 1 - MediaPortal Wiki
    MediaPortal now fully supports playing unencrypted Blu-ray discs.
    ...
    If the user wishes to play a commercial disc, then they will need to use a 3rd party on-the-fly decrypter such as AnyDVD HD or DVDFab Passkey Lite.
     

    tonewheelkev

    Portal Pro
    February 10, 2012
    402
    41
    Leeds
    Home Country
    United Kingdom United Kingdom
    Aaaagghhhh!! Now I realise what an 'external' player is....
    So, as is, no support in MP for encrypted blurays.
     

    mm1352000

    Retired Team Member
  • Premium Supporter
  • September 1, 2008
    21,577
    8,224
    Home Country
    New Zealand New Zealand
    Aaaagghhhh!! Now I realise what an 'external' player is....
    Respectfully, I'm not so sure that you do.
    An external player is an external program that is completely responsible for playing the media. For example, for a Blu-Ray you might use PowerDVD or ArcSoft Total Media.

    So, as is, no support in MP for encrypted blurays.
    No... but as the documentation says, you can use [free] decryption software to bypass encryption and other protection schemes. Once the protection schemes have been bypassed, MP should quite happily play the BR. This is not the same as using an external player.
    In other words: MP can play commercial BRs if the encryption is bypassed... and that's eminently doable.
     

    Users who are viewing this thread

    Similar threads

    Hi, First off: there are some issues with the latest Mediaportal (32bits vs 64bits), so that is one of the issues you're stumbling with. If you take the previous version (1.31) it should work as expected. For IPTV there is also a different option (with different pros and cons): Onlinevideos. I'm using that sometimes for my IPTV as...
    Hi, First off: there are some issues with the latest Mediaportal (32bits vs 64bits), so that is one of the issues you're stumbling...
    Hi I am trying to play a m3u file from my IPTV provider, but when I try to install the TV part of Media Portal v1.3.2 I get an...
    Replies
    1
    Views
    734
    I uninstalled MP, made sure no sub folders were left n any programmes folders, changed the computer name, rebooted, installed MP and set logs and rebooted and ran TVServer. Didn't do anything in regard to S Loopback adapter. I've been using NextPvr since the problem became insurmountable. Only reason it's not a good long term...
    I uninstalled MP, made sure no sub folders were left n any programmes folders, changed the computer name, rebooted, installed MP...
    I've been using MediaPortal for 20 or so years. Last night it recorded perfectly. This arvo it doesn't - will run videos but not...
    Replies
    24
    Views
    2K
    • Sticky
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the next release. We allocate about one month for Pre Release testing. In that time we will only fix bugs, after which comes the final release! Highlights of this release Bugfixes: [MP1-5201] - Fix MPC-HC...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    0
    Views
    371
    If I understand correctly, your device is combination of DVB-C tuner, router and some web access to play the channels in PC web browser. You can sniff http comunication with the help of Wireshark or Fiddler to determine channel url which can be used to create IPTV channel in TV server. If the url is not static(changes dynamically)...
    If I understand correctly, your device is combination of DVB-C tuner, router and some web access to play the channels in PC web...
    So, I appear to have done a successful install of Media Portal (MP2 vers. 2.5) on my Windows 10 machine but I can't get it to get...
    Replies
    7
    Views
    1K
    (egg in face) I had to dnld SD plugin mpe1 to re install. trying again Thnx
    (egg in face) I had to dnld SD plugin mpe1 to re install. trying again Thnx
    Pre Releases are provided as a way for the community to test and give feedback on all the exciting things we have lined up for the...
    Replies
    40
    Views
    5K
    Top Bottom