Youtube is broken...

Discussion in 'OnlineVideos' started by Hes, May 5, 2015.

  1. Hes

    Hes Portal Member

    Joined:
    December 7, 2009
    Messages:
    9
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Hi all,
    YouTube doesn't work anymore - I think that due to the old API that's being discontinued. In any case, I get "no URL" on every YouTube video I try.

    Is this easy to fix, or will we have to wait longer?

    Cheers, michael.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Hi,
    it's not an easy fix - I had to re-implement the entire site. I'm almost done (currently testing) so stay tuned just a bit longer.
     
    • Thank You! Thank You! x 9
    • Like Like x 2
  4. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Alright the new Site is published!

    You can no longer provide your credentials from within MediaPortal - the new API requires to open a browser and choose your YouTube account, so you can give OnlineVideos access to the required information. The token is then saved for later access. You can enable this functionality as usual from the context menu on the youtube site.
     
    • Thank You! Thank You! x 3
    • Like Like x 2
  5. 2102Michael

    2102Michael Portal Member

    Joined:
    December 17, 2010
    Messages:
    22
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    Austria Austria
    I believe you mean the Google button on the right upper side? There is a menue behind but I can not find anything that looks like "enable OnlineVideos" here.

    Do you mean the item "Connected TVs"?

    Pls help!

    Thanks in advance
    Michael
     
  6. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Update the site within MediaPortal, no need to manually open a browser... I was only talking about inside MP.
     
  7. 2102Michael

    2102Michael Portal Member

    Joined:
    December 17, 2010
    Messages:
    22
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    Austria Austria
    Now I can see e.g. videos from "My Playlist" or the "Last Viewed Videos". In other words, all videos that are related to my account with the exception of the "New Videos". Also, no other group opens (e.g. "Top Rated") - the only thing I see is the device no longer supported video.
     
    • Agree Agree x 1
  8. Remmerboy

    Remmerboy Portal Member

    Joined:
    June 19, 2008
    Messages:
    16
    Likes Received:
    1
    Ratings:
    +2 / 1
    Home Country:
    Denmark Denmark
    I'm glad you updated to new api.
    I'm trying to learn the new layout, but i can't find a setting, so the newest youtube videos shows first (the oldest videos shows first, which is very unhandy). And is it possible for you to add "New Videos" (directing to https://www.youtube.com/feed/subscriptions instead of https://www.youtube.com/subscription_manager)?

    edit:
    Actually, i think the sort option is broke. the youtube is sorted by viewcount and cannot be changed
     
    Last edited: May 7, 2015
    • Agree Agree x 1
  9. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
  10. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,826
    Likes Received:
    790
    Location:
    Nuenen
    Ratings:
    +1,158 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I think there's something else going on too:
    It seems that you reference stuff that isn't present in current release of onlinevideos:
    Looking for SiteUtils and Hosters in OnlineVideos.Sites.offbyone (Version: 1.0.0.3669, Compiled: 2015-05-07 11:26:56)
    Error loading SiteUtils and Hosters: Could not load type 'System.IProgress`1' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
     
  11. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Uh, maybe I forgot to embed an assembly - the v3 Api is actually .net 4.5 :( I had to pull some tricks to get it working, but on dev PC it works with current OV.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!