Youtube is broken... | Page 3

Discussion in 'OnlineVideos' started by Hes, May 5, 2015.

  1. andreyua

    andreyua Guest

    Ratings:
    +0 / 0
    How view sorted by date videos from 'my subscriptions". Now, I just must click on separate subscription. This is very ugly. I want view all videos in one list, like old behaviour.


     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,742
    Likes Received:
    1,417
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,846 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    i have same issues, no video url error, :( let me know if interested in logs. Thanks for your hard work on this.

    PS: Took me a while to figure find the youtube login setting.

    PS: Running latest version MP / OV / MP URL Splitter / LAV. Have tried reinstalling all of the above.
     
    Last edited: May 9, 2015
  4. Herr R aus B
    • Premium Supporter

    Herr R aus B MP Donator

    Joined:
    December 22, 2007
    Messages:
    241
    Likes Received:
    14
    Occupation:
    IT Project Leader
    Location:
    Berlin
    Ratings:
    +15 / 0
    Home Country:
    Germany Germany
    OK - i see... doing it the acurate german way - gut so, weitermachen! ;) then it's maybe rather a matter of time, when kodi's implementation will start failing on me :mad:, allthough they already use the new authorization stuff - at least, when starting YT there for the first time, you're given a keyphrase you have to enter at the YT site...

    danke anyway

    axel[DOUBLEPOST=1431158740][/DOUBLEPOST]
    also installed that one?
     
    Last edited: May 9, 2015
  5. Remmerboy

    Remmerboy Portal Member

    Joined:
    June 19, 2008
    Messages:
    16
    Likes Received:
    1
    Ratings:
    +2 / 1
    Home Country:
    Denmark Denmark
    @offbyone
    Is it possible to get subscription view like in the old behavior?
    Old behavior was subsOverview -> videoes (order by date). Now it's subsOverview -> playlistOverview -> videoes (order by viewcount that cannot be changed).
    To get directly into uploads, instead of using playlist.list function and then playlistItems.list you can directly use playlistItems.list by getting the upload playlistId from channels.list.
    For replacing newsubscription you can use activities.list call as mention in earlier post.

    ps.
    Is it possible to view/get sourcecode for your youtube code so i can try to understand the logic? I'm guessing wildly about how it functions :)
     
    Last edited: May 9, 2015
  6. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,742
    Likes Received:
    1,417
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,846 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    ^ ill try installing .net 4.5.2[DOUBLEPOST=1431164427][/DOUBLEPOST]
    yes. still have error.
     
    Last edited: May 9, 2015
  7. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    • Agree Agree x 1
  8. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,742
    Likes Received:
    1,417
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,846 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    No video url error.

    Latest version of;
    mp 1.11
    online videos 2.0
    latest version mp url splitter
    latest version lav
    mp .net 4.5.2

    attempted to play 2x video within OV plugin and a 3rd online trailer with trakt. Same error in GUI on attempt to playback. logs attached.

    thanks
    kiwi

    PS: happy to provide additional testing or give access to htpc via teamviewer if required.

    PPS: I wonder if the playback url is wrong:

    Code (Text):
    1.  
    2. 2015-05-09 15:04:55.488 [DEBG] [MPMain][01]: Preparing graph for playback, URL = 'http://r3---sn-cpb2p2x-53ae.googlevideo.com/videoplayback?mm=31&ip=210.54.38.4&sparams=dur%2Cid%2Cinitcwndbps%2Cip%2Cipbits%2Citag%2Cmime%2Cmm%2Cms%2Cmv%2Cpl%2Cratebypass%2Csource%2Cupn%2Cexpire&dur=157.477&ipbits=0&pl=24&itag=22&fexp=907263%2C916641%2C934954%2C9406841%2C9407536%2C9407575%2C9407713%2C9408142%2C9408312%2C9408706%2C9408779%2C9409061%2C9409172%2C9412511%2C9412773%2C9413150%2C948124%2C952612%2C952637%2C952642&mime=video%2Fmp4&sver=3&expire=1431162307&ratebypass=yes&key=yt5&signature=D10FFF02DDFBA8CC88180DD08F3949B9805FD986.40821632CF4A75D58D138195B5EAAB93F248E301&id=o-ABegVnXsJ8spZcqGP_gCj1Pi_QvkUxVUs3MoSGWcA5W_&mt=1431140646&source=youtube&upn=zk1wCJ8y-bc&mv=m&initcwndbps=2745000&ms=au&ext=.mp4'.
    3.  
     
  9. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    I guess you do not have the required filter installed.
    Your logs are missing a file like "MPUrlSourceSplitter.log" and the log says:
    [05-09 22:05:28,893] [MPMain ] [WARN ] Error adding 'MediaPortal Url Source Splitter' filter to graph: Exception from HRESULT: 0xFFFFFFFB

    Make sure you have this extensions installed:
    https://www.team-mediaportal.com/ex...diaportal-iptv-filter-and-url-source-splitter
    and it is registered after install. (Check with "graphstudio next" for example) If not do so manually.
     
  10. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Tried it and all my normal feeds are working like subscriptions/watch later, and playback is working as well, only notice a few small quirks:

    - Sorting not working

    If I select "Date" or any other sort method under Sort options and press refresh the sort remains the same even though that feed has valid dates like before, tested it with the subscription "Jay Leno's Garage".
    Previously the sort would have been relevance by default and I think it now is fixed to that, shows no error or debug info that I can include sadly.

    - Asks for Youtube auth in browser but re-asks on every MePo restart

    Not sure why but it seems I have to permit OV on Youtube on every MePo restart, no big deal as it's one click but thought I should mention it.
    Also no option in the OV MePo config (in Mediaportal Configuration) to set permission beforehand, might be an issue if users have Mediaportal always on top as they wouldn't be able to get to the browser window.
     
    Last edited: May 9, 2015
  11. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    The authorization Cookie is saved in mediaportal.xml. I am not asked on every mp start. How are you closing mp? I think the file is saved on mp closing, so if you kill the task you might get the described behavior.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!