TOU.TV doesn't works | Page 8

Discussion in 'OnlineVideos' started by kilik360, May 16, 2011.

  1. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    You mentioned, that you are windows 8. Perhaps that is the problem.

     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    MPUrlSourceSplitter.log is unfortunately not included in the zip file. Any chance you could post that separately?
     
  4. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    He can't - it seems the Filter does not register anymore correctly on Win8 - OnlineVideos.log says it couldn't find a filter by name and I'm pretty sure it's our ;)
     
  5. georgius
    • Premium Supporter

    georgius Retired Team Member

    Joined:
    October 31, 2010
    Messages:
    1,376
    Likes Received:
    437
    Gender:
    Male
    Occupation:
    Software Architect
    Location:
    Bratislava
    Ratings:
    +668 / 0
    Home Country:
    Slovakia Slovakia
    Show System Specs
    If you have GraphStudioNext, you can check if MP Url Source Splitter is registered:
    1. run GraphStudioNext
    2. choose Graph -> Insert Filter
    3. in list try to find MediaPortal Url Source Splitter
    If splitter is not in list, then is not registered. If it is registered, on right side you can see in File Path property, where is located. Maybe reason is only bad download of filter files. I'm attaching builds for sure.

    Edit: Removed builds. Wrong version.
     
    Last edited: January 16, 2013
    • Like Like x 2
  6. Benoit LeBlanc

    Benoit LeBlanc Portal Member

    Joined:
    April 23, 2012
    Messages:
    17
    Likes Received:
    2
    Gender:
    Male
    Location:
    Montreal, Quebec
    Ratings:
    +2 / 0
    Home Country:
    Canada Canada
    Managed to get it to work. A great job guys!

    You have to make sure that the Adobe Flash Player plugin for Internet Explorer is installed.

    If I may recommend something before making the changes "public": Would there be a way to display an error message if the plugin is not installed? Or maybe redirect to the adobe flash player page?

    I had to check in the MPUrlSourceSplitter.log file to determine this... I'm sure a lot of users will get confused by this.

    Thanks again guys!
     
    • Like Like x 1
  7. sbourdon

    sbourdon Portal Member

    Joined:
    July 10, 2012
    Messages:
    22
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Canada Canada
    Hello,

    I would like to test your modifications on Windows 8 but unfortunately I'm totally lost as to what I should do...
    Could you give me a step-by-step tutorial as to what I should do to install the latest version of OnlineVideos?

    I'm using a plain 1.4.0.0 installation right now.

    Many thanks!
    P.S.: I'm using Chrome so if Internet Explorer is required to get this thing working, just let me know! ;)
     
    Last edited: January 15, 2013
  8. Benoit LeBlanc

    Benoit LeBlanc Portal Member

    Joined:
    April 23, 2012
    Messages:
    17
    Likes Received:
    2
    Gender:
    Male
    Location:
    Montreal, Quebec
    Ratings:
    +2 / 0
    Home Country:
    Canada Canada
    Here's a recap based on the previous posts and my personal installation, hope this helps. I'm on Windows 7 but it should work the same...



    1. In Mediaportal, remove Tou.TV from your local sites.

    2. Close the MediaPortal application

    3. for backup purposes, make a copy of the folder C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter

    4. Unzip the content of the file at post #74 in the MPUrlSourceSplittler folder.

    5. Register the ActiveX component by opening a command shell. (windows-R, type "cmd.exe") and typing the following commands:

    cd "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter"
    regsvr32 MPUrlSourceSplitter.ax

    6. Open Internet explorer, and go at the following address to install the Adobe Flash Player Plugin:
    http://get.adobe.com/flashplayer/

    7. Launch MediaPortal

    8. in OnlineVideos, add Tou.TV to your sites again. This should result in the latest version of the dll being automatically downloaded.
    (You can also force an update from the Online Videos menu).

    Voilà!

    Benoit
     
  9. corporate_gadfly

    corporate_gadfly Portal Pro

    Joined:
    May 17, 2011
    Messages:
    396
    Likes Received:
    68
    Ratings:
    +72 / 0
    Home Country:
    Canada Canada
    You would want to do this with Administrator privileges.

    Good luck
     
  10. sbourdon

    sbourdon Portal Member

    Joined:
    July 10, 2012
    Messages:
    22
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Canada Canada
    Many thanks for your replies.

    Before doing anything, I did a test with my current installation. I ran the following command, with admin privileges:
    Code (Text):
    1. cd "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MPUrlSourceSplitter"
    2.  
    3. regsvr32 MPUrlSourceSplitter.ax
    I then received the following message:
    Code (Text):
    1. DllReggisterServer in MPUrlSourceSplitter.ax done.
    Which is way better than the error message I was getting yesterday, as reported in post #68! ;)

    I will now go ahead and test everything once more, following your indications.

    P.S.: Under Windows 8, Adobe Flash is included in Internet Explorer, as reported by this message, at the address http://get.adobe.com/flashplayer/ :
     
  11. sbourdon

    sbourdon Portal Member

    Joined:
    July 10, 2012
    Messages:
    22
    Likes Received:
    3
    Ratings:
    +3 / 0
    Home Country:
    Canada Canada
    OK, so here are the results.

    Good news: I was able to register MPUrlSourceSplitter.ax!
    Unfortunately, I'm still getting an endless "0.0% cached" message when selecting anything in Tou.TV (but everything else works fine -- like YouTube -- which was not the case yesterday).

    Could this be because I'm not using the latest DLL that IE is suppose to automatically download?
    Could you attach that file here and tell me where to save it so I could test it on my PC?

    Thank you very much!
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!