Windows CE (1 Viewer)

S

stoffl

Guest
Hi,

is it possible to run MP under Windows CE?

Regards
Stoffl
 

Callifo

Retired Team Member
  • Premium Supporter
  • December 7, 2004
    1,439
    21
    Adelaide, Australia
    Home Country
    Unless its gone a long way since I used it last no. Cant see it having the SB engine or DX9 instructions. Even if it did the unit wont have a video card capable of dx9 instructions. But on another matter what device using CE would have the power to run MP?
     
    S

    stoffl

    Guest
    Hello,

    thanks for fast reply...

    I want to use it on an Windows CE 5.0 STB....

    What exactly is the SB engine?

    Stoffl
     

    mzemina

    Retired Team Member
  • Premium Supporter
  • February 23, 2005
    2,065
    14
    Tulsa, OK
    Home Country
    United States of America United States of America
    I would be great if (in future a release) we could use WinCE as a thin client with wifi connectivity to control MP.

    A skinnable remote control. Forget about remote control limitations!
     

    samuel337

    Portal Pro
    August 25, 2004
    772
    0
    Melbourne, Australia
    SB Engine - Stream Buffering Engine, the thing that MP uses to time-shift. They have a new one coming up though so it doesn't have to use the Microsoft SB Engine.

    If you use it as a Windows CE thin-client, the end result will be like the Media Center Extenders, where all the animations have been left out. It'll be a totally different project then, because of the need to remove DX9 instructions and probably put in GDI or GDI+ instructions.

    Sam
     
    S

    stoffl

    Guest
    thanks again....

    but it would be possible to run MP with Windows Embedded XP SP2 ??

    The following Windows XP Professional technologies are new for Windows Embedded XP SP2:

    * .NET Framework 1.1
    * DirectX 9.0c
    * Terminal Server Remote Desktop
    * Windows Firewall
    * Windows Media Player 9.0
     

    samuel337

    Portal Pro
    August 25, 2004
    772
    0
    Melbourne, Australia
    Theoretically yes, as Windows XP Embedded is just the usual Windows XP except its componentised. You'll probably need to experiment to work out which packages to leave out and which to add. You'll definitely need .NET framework 1.1, and DirectX 9.0c.

    Sam
     

    Autoper

    Portal Pro
    January 24, 2005
    87
    0
    Stavanger, Norway
    MP works great on WinXP SP2 Embedded :) On one of my pc's I'm running MP as a shell using minlogon for logon and the EWF filter on the system volume. Also using the hibernate once, start many function for fast boot.
    The complete installation is about 300MB and is booting in about 20 sek.

    But there is a problem related to DirectX 9.0c. The latest XPEmb update is containing DX9.0c, but when you try to start MP it tells you there is no DX9.0c installed. The reason for this problem is a wrong reg key.
    I can't remember what reg key you have to edit or the correct value. Google it, and you will find info on how to fix it...

    Another problem is when you enter the MP setup there is a .NET error. Just press continue.

    The most anoying thing about the XPEmb evaluation copy (I don't know if this is an issue for the full version) is that it is impossible to change the XP boot screen in any normal way :(
    So for now I'm using the "/bootlogo /noguiboot" switches in boot.ini to get my custom boot screen. (to use the /bootlogo switch place a 16 color 640x480 image file called boot.bmp in the system root).
     

    Users who are viewing this thread

    Similar threads

    So far I have installed an MP1 server and MP1 clients. Now I want to connect a Raspi to the MP server. Is there a HowTO for this? I installed the MPserverKodi plugin, shared the corresponding directories, and activated smb under Windows. Nevertheless, Kodi remains with the message 'PVR Manager is being tested: 0%
    So far I have installed an MP1 server and MP1 clients. Now I want to connect a Raspi to the MP server. Is there a HowTO for this? I...
    So far I have installed an MP1 server and MP1 clients. Now I want to connect a Raspi to the MP server. Is there a HowTO for this? I...
    Replies
    0
    Views
    480
    I've setup my HDHomeRun in MP1 as (4) IPTV cards rather than Atsc. I can see the (4) Atsc cards, but just have them disabled. I did it this way so I didn't have to edit the channel names every time tested a new TV-server install. Anyway, it works. I don't know if this would get you past the BDA driver issue. I'll provide more...
    I've setup my HDHomeRun in MP1 as (4) IPTV cards rather than Atsc. I can see the (4) Atsc cards, but just have them disabled. I...
    I am brand new to MediaPortal. I have installed MP 2.4.1 on Windows 10. It is a fresh install and fully up to date. I have an...
    Replies
    19
    Views
    2K
    Thank you Cybersymian, that solution works perfectly. Thanks for the prompt reply and solution.
    Thank you Cybersymian, that solution works perfectly. Thanks for the prompt reply and solution.
    I recently upgraded to Mediaportal 1.33 x64 version. Everything works great, except when I drop out to Windows and want to go back...
    Replies
    2
    Views
    590
    hi team, this error seemed to literally start overnight - not as a result of any windows update or related. tried all the usual things TVGuide shows no data available in MP2 and after running TVSetup and telling WebEPG to grab now I am presented with the attached error screen - TvSetup then crashes out. I have run a repair on...
    hi team, this error seemed to literally start overnight - not as a result of any windows update or related. tried all the usual...
    hi team, this error seemed to literally start overnight - not as a result of any windows update or related. tried all the usual...
    Replies
    0
    Views
    285
    MP1 MP2 No TV Service DE
    Looking at recent activity on the web site, it has been 4 weeks since any of the MP2 developers have been active. They may be taking a short (or an extended) break. For this reason I would suggest that you uninstall MP2 and re-install MP1. The 1.33 version is recommended (in either the 32-bit or 64-bit version). Also, it is pretty...
    Looking at recent activity on the web site, it has been 4 weeks since any of the MP2 developers have been active. They may be...
    Hi, I've recently installed Media Portal 2, having first removed an older version of MP1, but am having issues with live TV. It...
    Replies
    1
    Views
    440
    Top Bottom