Youtube is broken... | Page 5

Discussion in 'OnlineVideos' started by Hes, May 5, 2015.

  1. 2102Michael

    2102Michael Portal Member

    Joined:
    December 17, 2010
    Messages:
    22
    Likes Received:
    0
    Ratings:
    +1 / 0
    Home Country:
    Austria Austria



     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    Couldn't it re-sort the entire list after it has retrieved it from Youtube on every new page request?

    On the other hand that might mean changing a lot of core code to just fit it to their for now limited API, doubt that Youtube is gonna keep it this way as the Smart TV / Embedded solutions should have the same issues already which is the bulk of the lot.

    /edit: never mind thought that the feed was pre-fetched in the background for subscriptions, so yeah no real no way to sort them beforehand :(
     
    Last edited: May 12, 2015
  4. Herr R aus B
    • Premium Supporter

    Herr R aus B MP Donator

    Joined:
    December 22, 2007
    Messages:
    241
    Likes Received:
    14
    Occupation:
    IT Project Leader
    Location:
    Berlin
    Ratings:
    +15 / 0
    Home Country:
    Germany Germany
    great job - as usual - thanks :)

    btw: is the amazon prime site knwn to be working? i get the video lists displayed, but starting any video results in error messages regarding MP rsp. plugin being unable to resolve ruls and stuff... should this site be working at different installations, i'll post the logs and so on... :) btw. it worked in kodi for some days, but actually same situation - nothing :)
     
  5. Remmerboy

    Remmerboy Portal Member

    Joined:
    June 19, 2008
    Messages:
    16
    Likes Received:
    1
    Ratings:
    +2 / 1
    Home Country:
    Denmark Denmark
    Isn't possible to sort by date after you fetched the videos in playlist? Every video has a "publishedAt" where it should be possible to use a sort command.
     
  6. kiwijunglist
    • Team MediaPortal

    kiwijunglist Super Moderator

    Joined:
    June 10, 2008
    Messages:
    6,742
    Likes Received:
    1,417
    Occupation:
    Doctor
    Location:
    New Zealand
    Ratings:
    +1,846 / 9
    Home Country:
    New Zealand New Zealand
    Show System Specs
    My problem related to "no video url" seems mostly fixed.

    link to my post in relevant thread

    Show Spoiler

    File list prior to uninstall / delete folder / reinstall
    Show Spoiler
    C:\Program Files (x86)\Team Mediaportal\MPUrlSourceSpiltter\
    avcodec-mpurlsourcesplitter-54.dll
    avformat-mpurlsourcesplitter-54.dll
    avutil-mpurlsourcesplitter-51.dll
    libcurl.dll
    MPUrlSourceSplitter.ax
    MPUrlSourceSplitter_Afhs_Decryption_Akamai.dll
    MPUrlSourceSplitter_libcurl.dll
    MPUrlSourceSplitter_Parser_Asx.dll
    MPUrlSourceSplitter_Parser_Default.dll
    MPUrlSourceSplitter_Parser_F4M.dll
    MPUrlSourceSplitter_Parser_M3U8.dll
    MPUrlSourceSplitter_Parser_MPEG2TS.dll
    MPUrlSourceSplitter_Parser_MSHS.dll
    MPUrlSourceSplitter_Protocol_Afhs.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Akamai.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Default.dll
    MPUrlSourceSplitter_Protocol_Http.dll
    MPUrlSourceSplitter_Protocol_M3U8.dll
    MPUrlSourceSplitter_Protocol_Mms.dll
    MPUrlSourceSplitter_Protocol_Mshs.dll
    MPUrlSourceSplitter_Protocol_Rtmp.dll
    MPUrlSourceSplitter_Protocol_Rtsp.dll
    MPUrlSourceSplitter_Protocol_Udp.dll


    1. Uninstalled via MPEM (MP Client not running, TV Server not installed)
    2. Manually deleted folder
    3. Restarted Computer
    4. Installed MP IPV & URL Source Splitter via MPEM (Ran as administrator) v2.19.5600
    5. Restarted Computer
    6. Problem mostly fixed.

    I seem to be able to play non local trailers in trakt now (wasn't working before). There are a some videos within online videos youtube that give no url error, but I suspect that is an O.V. problem. I can now play trailers in trakt, so that is great.

    I thought I had manually deleted the mpurlsourcesplitter folder before, but either
    1. I remember wrong and I didn't delete the folder
    2. It now worked because I restarted between uninstall+deleting folder and reinstallation
    3. Some other reason.

    Directory listing after above steps (Note: the absence of libcurl.dll)
    Show Spoiler
    avcodec-mpurlsourcesplitter-54.dll
    avformat-mpurlsourcesplitter-54.dll
    avutil-mpurlsourcesplitter-51.dll
    MPUrlSourceSplitter.ax
    MPUrlSourceSplitter_libcurl.dll
    MPUrlSourceSplitter_Parser_Default.dll
    MPUrlSourceSplitter_Parser_F4M.dll
    MPUrlSourceSplitter_Parser_M3U8.dll
    MPUrlSourceSplitter_Parser_MPEG2TS.dll
    MPUrlSourceSplitter_Parser_MSHS.dll
    MPUrlSourceSplitter_Protocol_Afhs.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Akamai.dll
    MPUrlSourceSplitter_Protocol_Afhs_Decryption_Default.dll
    MPUrlSourceSplitter_Protocol_Http.dll
    MPUrlSourceSplitter_Protocol_M3U8.dll
    MPUrlSourceSplitter_Protocol_Mshs.dll
    MPUrlSourceSplitter_Protocol_Rtmp.dll
    MPUrlSourceSplitter_Protocol_Rtsp.dll
    MPUrlSourceSplitter_Protocol_Udp.dll

     
  7. eetaylog

    eetaylog Portal Pro

    Joined:
    March 6, 2007
    Messages:
    874
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Electronics technician
    Location:
    South London
    Ratings:
    +44 / 2
    Home Country:
    England England
    Show System Specs
    Been following, thanks for the update. I seem to now have a problem where 'Add site to my list' in the Manage Sites area doesnt add it to my links. It still shows up as greyed/blued out in the global list (indicating that the plugin assumes its been added to my list), but when i go to My Sites, Youtube isnt there.

    Any ideas?
     
  8. Mjollnir64

    Mjollnir64 Portal Member

    Joined:
    February 27, 2012
    Messages:
    5
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    Is there any way to get Channel listings? I was using this feature heavily before the API change, but now the RSS no longer works. Subscribing to a user or channel works fine, except that the "uploads by " feature is randomly ordered. I realize that is a YouTube "feature" and nothing you can do about sorting when receiving partial collections. Maybe something in the Edit Sites page in configuration where we could enter a channel name and used as a permanent API search query?

    Thanks for your hard work on this. OnlineVideos is one of the critical plugin's for MediaPortal, IMO.
     
    • Like Like x 2
  9. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    That should work according to this user as well (at least for playlists):

    http://stackoverflow.com/a/28065737/2770404
     
  10. Mjollnir64

    Mjollnir64 Portal Member

    Joined:
    February 27, 2012
    Messages:
    5
    Likes Received:
    2
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I have tried various permutations of that but cannot get the videos to list in the GUI.

    This worked in v2:
    Code (XML):
    1.   <Category xsi:type="RssLink" name="Lindybeige">http://gdata.youtube.com/feeds/api/videos?orderby=published&amp;author=lindybeige</Category>
    2.  
    This does not work in v3, although in a browser it does bring back data (in json format):
    Code (XML):
    1.    <Category xsi:type="RssLink" name="Lindybeige">https://www.googleapis.com/youtube/v3/search?part=snippet&amp;type=video&amp;order=date&amp;maxResults=50&amp;channelId=UC9pgQfOXRsp4UKrI8q0zjXQ&amp;key={APIKEY}</Category>
    2.  
    The {APIKEY} is one I grabbed off some StackExchange post, so won't post it here. Once I get it working, I figure I will have to request my own to use.

    Any thoughts?
     
  11. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    I have not yet implemented static categories, so you can't currently put them into the xml. They are ignored!
    Either one of you quickly implements it or wait for me to get it done - but I'll be gone until next week. ;)
     
    • Like Like x 4
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!