Howto: Get MCE/Harmony working with Antec Fusion (1 Viewer)

Spragleknas

Administrator
  • Team MediaPortal
  • December 21, 2005
    9,473
    1,822
    Located
    Norway Norway
    Country flag
    • Thread starter
    • Admin
    • #3
    Argh... kidding me? Well, the guide works fine as well :D

    How come the files that were changed was so much newer?
    And be aware that this is using the IR receiver that comes with the Fusion case.
     

    frankwaan

    Portal Pro
    August 8, 2008
    90
    0
    Hengelo (O)
    Netherlands Netherlands
    Hello,

    Having problems getting IR commands from a Logitech Harmony 525 to my iMon reciever (in an Antec Veris Remote case).
    Got the iMon manager installed (but disabled). This happens when I want to use IR Server Suite. With the iMon manager
    software enabled, I can recieve IR signals.

    iMon manager version: 7.40.0806
    iMon Firmware version: 0x380102

    I really would like to use IRSS, because of it's neat intergration with MP.

    Anyone with this iMon unit got it to work, or do I have to 'fall-back' to the iMon manager?

    Help would be very appreciated!
    Thanks in advance!
    Frank

    <EDIT> added some logs. it looks like the reciever isn't beeing recognizedat all.
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    46
    Milano, Italy
    Italy Italy
    Country flag
    frankwann,

    from your logs I can see:

    2008-11-28 13:29:23.004025 - Start(): No iMon devices found!

    this happens on some system when iMON hardware is selected. As you have a Harmony, try configuring it as a MCE remote and then select MCE in IRSS config.
    Works fine here.

    Simone
     

    frankwaan

    Portal Pro
    August 8, 2008
    90
    0
    Hengelo (O)
    Netherlands Netherlands
    Hi Chemelli,

    Thanks for the quick reply! Unfortunatly this won't work either, because I get the following exception:

    2008-11-28 14:44:22.963825 - Error: System.InvalidOperationException: Device not found
    bij InputService.Plugin.MicrosoftMceTransceiver.Start() in D:\Dev\MediaPortal\Plugins\IR Server Suite\IR Server Plugins\Microsoft MCE Transceiver\MicrosoftMceTransceiver.cs:regel 372
    bij InputService.InputService.OnStart(String[] args) in D:\Dev\MediaPortal\Plugins\IR Server Suite\Input Service\Input Service\InputService.cs:regel 284

    Concerning the firmware version - could that be a problem?
     

    chemelli

    Retired Team Member
  • Premium Supporter
  • September 28, 2006
    6,159
    2,264
    46
    Milano, Italy
    Italy Italy
    Country flag
    I think I was not so clear...you have to tick imon in IRSS input service and under advanced select hardware MCE.

    Simone
     

    frankwaan

    Portal Pro
    August 8, 2008
    90
    0
    Hengelo (O)
    Netherlands Netherlands
    Hi Simone,

    OK did that.
    The logs are attached again.
    However, I can not test it now so theoreticaly it COULD work.

    edit: It still doesn't seem to recieve IR signals. The logs stay the same and I tried every iMon .dll from the IRSS forum post.

    I'll repost the iMon specs:

    iMon manager - V 7.40.0806
    iMon firmware - V 0x380102 (LCD HID OEM)

    Also: where can I find the source code for IRSS? I'm a .NET developer myself, maybe I can help others too.

    Thanks,
    Frank
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom