Typhoon PVR (aka TV Walker and others) (1 Viewer)

manutoky

Portal Member
December 23, 2004
12
0
Stuttgart/Germany
Hi,

I own a Typhhon PVR which seems to be identical to the Lifeview TV Walker. Is there chance to use MP with it? I searched the boards but didn't find a success report :)

Thanks,
manutoky
 

manutoky

Portal Member
December 23, 2004
12
0
Stuttgart/Germany
Did that...

Did that...
...and had limited success. I can setup the card, edit its properties (but they don't get saved). If I try to Autotune channels it gets ultra-slow, no chance to setup anything. I think the card is in DIVX-Mode with 6 MBits/s which seems to be too much for my USB1.1 setup. I'm trying this tomorrow on my USB2.0 capable computer.
With Graphedit I found working graphs. See there: http://manutoky.homeip.net/

Hope this will help someone...

Cheers

manutoky
 

dman_lfc

Retired Team Member
  • Premium Supporter
  • July 28, 2004
    1,772
    30
    UK
    Home Country
    New Zealand New Zealand
    From what I see on the graphs it should be able to get working.
    Mars Warrior is re-writing some new TV code so these pictures and graph files will help him out alot.

    DMAN
     
    N

    nigelrmtaylor

    Guest
    TV Walker / Packard Bell PB-TV200 - getting closer

    I've just spent a couple of days working with Media Portal and a Packard Bell branded TV Walker Mini.

    So far, I've got it doing live TV and recording but with no sound. I'll keep plugging away al keep you all informed
     

    Mars Warrior

    Portal Pro
    August 26, 2004
    158
    2
    Airy Crater, Mars
    Home Country
    Re: Did that...

    manutoky said:
    Did that...
    ...and had limited success. I can setup the card, edit its properties (but they don't get saved). If I try to Autotune channels it gets ultra-slow, no chance to setup anything. I think the card is in DIVX-Mode with 6 MBits/s which seems to be too much for my USB1.1 setup. I'm trying this tomorrow on my USB2.0 capable computer.
    With Graphedit I found working graphs. See there: http://manutoky.homeip.net/

    Hope this will help someone...

    Cheers

    manutoky
    How's the progress on this one???
    It seems Frodo added the card to the list (see: http://www.maisenbachers.de/dokuw/install:mytv_requirements), but it is untested. Could you give it a try??
     

    manutoky

    Portal Member
    December 23, 2004
    12
    0
    Stuttgart/Germany
    I'm waiting for a new release with the new TV functioniality to test my card. I don't have time to setup CVS and compile MP for myself. I will be more than happy to try it :wink:

    manutoky
     

    manutoky

    Portal Member
    December 23, 2004
    12
    0
    Stuttgart/Germany
    Hi,

    took some time and compiled the current CVS version with "UseCaptureCardDefinitions". I added parts of the capture.log file which seems to be okay as far as I can tell.

    But when I'm trying to configure MP I run into the following problem:
    After I added the capture card and imported some channels I would like to use the auto-tune button to scan the frequencies. The card seems to lock onto the right channels but I don't get video and audio and the channel list for mapping the frequencies is empty.

    manutoky

    BTW, you could add the "UseCaptureCardDefinitions"-target to the mediaportal.build file. It took a while to understand why debug isn't using the .xml file.

    Code:
    07.01.2005 13:51:33 SinkGraphEx:CreateGraph() IN
    07.01.2005 13:51:33 SinkGraphEx: Create new filter graph (IGraphBuilder)
    07.01.2005 13:51:33 SinkGraphEx: Get the Capture Graph Builder (ICaptureGraphBuilder2)
    07.01.2005 13:51:33 SinkGraphEx: Link the CaptureGraphBuilder to the filter graph (SetFiltergraph)
    07.01.2005 13:51:33 SinkGraphEx: Add graph to ROT table
    07.01.2005 13:51:33 SinkGraphEx: Adding configured filters...
    07.01.2005 13:51:33 SinkGraphEx:  adding filter <Typhoon TV PVR CrossBar> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{a799a801-a46d-11d0-a18c-00a02401dcd4}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  Added filter <Typhoon TV PVR CrossBar> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{a799a801-a46d-11d0-a18c-00a02401dcd4}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  adding filter <Typhoon TV PVR Audio> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{a799a802-a46d-11d0-a18c-00a02401dcd4}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  Added filter <Typhoon TV PVR Audio> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{a799a802-a46d-11d0-a18c-00a02401dcd4}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  adding filter <Typhoon TV PVR A/V Capture> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  Added filter <Typhoon TV PVR A/V Capture> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{65e8773d-8f56-11d0-a3b9-00a0c9223196}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  adding filter <Typhoon TV PVR Tuner> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{a799a800-a46d-11d0-a18c-00a02401dcd4}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx:  Added filter <Typhoon TV PVR Tuner> with moniker <@device:pnp:\\?\usb#vid_10fd&pid_de00#5&550799a&0&7#{a799a800-a46d-11d0-a18c-00a02401dcd4}\{9b365890-165f-11d0-a195-0020afd156e4}>
    07.01.2005 13:51:33 SinkGraphEx: Adding configured filters...DONE
    07.01.2005 13:51:33 SinkGraphEx: Adding configured pin connections...
    07.01.2005 13:51:33 SinkGraphEx:  Connecting <Typhoon TV PVR Tuner>:0 with <Typhoon TV PVR CrossBar>:0
    07.01.2005 13:51:33 SinkGraphEx:   Found sourcePin: <0> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Found sinkPin: <0> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Pins connected...
    07.01.2005 13:51:33 SinkGraphEx:  Connecting <Typhoon TV PVR Tuner>:1 with <Typhoon TV PVR Audio>:0
    07.01.2005 13:51:33 SinkGraphEx:   Found sourcePin: <1> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Found sinkPin: <0> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Pins connected...
    07.01.2005 13:51:33 SinkGraphEx:  Connecting <Typhoon TV PVR Audio>:0 with <Typhoon TV PVR CrossBar>:3
    07.01.2005 13:51:33 SinkGraphEx:   Found sourcePin: <0> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Found sinkPin: <3> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Pins connected...
    07.01.2005 13:51:33 SinkGraphEx:  Connecting <Typhoon TV PVR CrossBar>:0 with <Typhoon TV PVR A/V Capture>:0
    07.01.2005 13:51:33 SinkGraphEx:   Found sourcePin: <0> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Found sinkPin: <0> <System.__ComObject>
    07.01.2005 13:51:33 SinkGraphEx:   Pins connected...
    07.01.2005 13:51:33 SinkGraphEx: Adding configured pin connections...DONE
    07.01.2005 13:51:33 VideoCaptureDevice: found output pin
    07.01.2005 13:51:33 VideoCaptureDevice:HW MPEG2 encoder:True MCE device:False
    07.01.2005 13:51:33 VideoCaptureDevice:get Video stream control interface (IAMStreamConfig)
    07.01.2005 13:51:33 VideoCaptureDevice:got IAMStreamConfig for Capture
    07.01.2005 13:51:33 VideoCaptureDevice:got IAMStreamConfig for Preview
    07.01.2005 13:51:33 SinkGraphEx: Capturing:720x576
    07.01.2005 13:51:33 mpeg2:add new MPEG2 Demultiplexer to graph
    07.01.2005 13:51:33 mpeg2:create video out pin on MPEG2 demuxer
    07.01.2005 13:51:33 mpeg2:create audio out pin on MPEG2 demuxer
    07.01.2005 13:51:33 mpeg2:find MPEG2 demuxer input pin
    07.01.2005 13:51:33 mpeg2:found MPEG2 demuxer input pin
    07.01.2005 13:51:33 SinkGraph:Connect VideoCapture device to MPEG2Demuxer filter
    07.01.2005 13:51:36 SinkGraph:find MPEG2 demuxer input pin
    07.01.2005 13:51:36 SinkGraph:found MPEG2 demuxer input pin
    07.01.2005 13:51:38 SinkGraph:FAILED to connect Encoder->mpeg2 demuxer:80040217
    07.01.2005 13:51:38 mpeg2:MPEG2 demuxer map MPG stream 0xe0->video output pin
    07.01.2005 13:51:38 mpeg2:mapped MPEG2 demuxer stream 0xe0->video output 
    07.01.2005 13:51:38 mpeg2:MPEG2 demuxer map MPG stream 0xc0->audio output pin
    07.01.2005 13:51:38 mpeg2:mapped MPEG2 demuxer stream 0xc0->audio output
    07.01.2005 13:51:38 SinkGraphEx:CreateGraph() OUT
    07.01.2005 13:51:38 SinkGraph:StartViewing()
    07.01.2005 13:51:38 add filter:InterVideo Video Decoder to graph
    07.01.2005 13:51:39 added filter:InterVideo Video Decoder to graph
    07.01.2005 13:51:39 add filter:InterVideo Audio Decoder to graph
    07.01.2005 13:51:39 added filter:InterVideo Audio Decoder to graph
    07.01.2005 13:51:39 SinkGraph:TuneChannel() tune to channel:2
    07.01.2005 13:51:39 SinkGraph:TuneChannel() tuningspace:0 country:31 tv standard:None cable:False
    07.01.2005 13:51:45 SinkGraph:TuneChannel() tuned to 49,75 MHz. tvformat:PAL_B
    07.01.2005 13:51:45 FixCrossbarRouting: use tuner:True use cvbs#1:False use cvbs#2:False use svhs:False
    07.01.2005 13:51:45  Find crossbar:#1
    07.01.2005 13:51:45   crossbar found:1
    07.01.2005 13:51:45     crossbar has 5 inputs and 2 outputs
    07.01.2005 13:51:45      check:in#0->out#0 / Video_Tuner -> Video_VideoDecoder
    07.01.2005 13:51:45      connect
    07.01.2005 13:51:48     connect success
    07.01.2005 13:51:48      check:in#1->out#0 / Video_Composite -> Video_VideoDecoder
    07.01.2005 13:51:48      check:in#2->out#0 / Video_SVideo -> Video_VideoDecoder
    07.01.2005 13:51:48      check:in#3->out#1 / Audio_Tuner -> Audio_AudioDecoder
    07.01.2005 13:51:48      connect
    07.01.2005 13:51:48     connect success
    07.01.2005 13:51:48      check:in#4->out#1 / Audio_Line -> Audio_AudioDecoder
    07.01.2005 13:51:48  Find crossbar:#2
    07.01.2005 13:51:48   no more crossbars.:0x80004005
    07.01.2005 13:51:48 crossbar routing done
    07.01.2005 13:51:48 mpeg2:StartViewing()
    07.01.2005 13:51:48 mpeg2:demux video out connected 
    07.01.2005 13:51:49 mpeg2:demux audio out connected 
    07.01.2005 13:51:49 mpeg2:StartViewing() start mediactl
    07.01.2005 13:51:49 mpeg2:StartViewing() started mediactl:0x1
    07.01.2005 13:51:49 SinkGraph:StartViewing() started 720x576
    07.01.2005 13:51:49 SinkGraph:StartViewing()
    07.01.2005 13:51:49 SinkGraph:TuneChannel() tune to channel:3
    07.01.2005 13:51:50 SinkGraph:TuneChannel() tuned to 55,25 MHz. tvformat:PAL_B
     

    manutoky

    Portal Member
    December 23, 2004
    12
    0
    Stuttgart/Germany
    Tested with 0.1.0.4 and got the same results...

    This seems to be odd (part of the log file):
    Code:
    08.01.2005 12:39:39 SinkGraphEx:   Pins connected... 
    08.01.2005 12:39:39 SinkGraphEx: Adding configured pin connections...DONE 
    08.01.2005 12:39:39 GetString() GetStructure is not supported 
    08.01.2005 12:39:39 GetString() property is not supported 
    08.01.2005 12:39:39 GetString() GetStructure is not supported 
    08.01.2005 12:39:39  driver version: fw version: 
    08.01.2005 12:39:39  encoding:Cbr bitrate:0 MBps peak:0 MBps 
    08.01.2005 12:39:39 GetByteValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39 GetIntValue() property is not supported 
    08.01.2005 12:39:39  gopsize:0 closedgop:False invtelecine:False format:NTSC size:720x480 output:PROGRAM

    manutoky
     

    Mars Warrior

    Portal Pro
    August 26, 2004
    158
    2
    Airy Crater, Mars
    Home Country
    Manutoky.

    Something is obviously wrong, can't say exactly what, but:

    1:
    Code:
    07.01.2005 13:51:33 SinkGraph:Connect VideoCapture device to MPEG2Demuxer filter 
    07.01.2005 13:51:36 SinkGraph:find MPEG2 demuxer input pin 
    07.01.2005 13:51:36 SinkGraph:found MPEG2 demuxer input pin 
    07.01.2005 13:51:38 SinkGraph:FAILED to connect Encoder->mpeg2 demuxer:80040217
    Tells me that if the encoder cannot connect to the demux, you don't have sound and/or video...

    2.
    In the first logging it is obvious that you have a PAL system.
    In the second logging some NTSC format is displayed (a weird one btw)

    I can't say the cause of the first problem, but the second problem might be related to the first one, as the connection failure might lead to unexpected video formats for the demux...
     

    Users who are viewing this thread

    Similar threads

    @CyberSimian Thank you very much. That has worked!!
    @CyberSimian Thank you very much. That has worked!!
    Do live TV subtitles work for TV in Australia? If so what are the settings? I am a 74 year old with hearing impairment and have...
    Replies
    12
    Views
    2K
    And if you use the comskip plugin, the file is locked during the process of comm removal. ;)
    And if you use the comskip plugin, the file is locked during the process of comm removal. ;)
    I'm about to do a Win 7 to Win 10 upgrade on a disk that has 2 partitions. The second partition holds all the recorded tv files so...
    Replies
    2
    Views
    808
    @Nordfinn I think you have a statement now and could test it. I’ve no TV channels with multichannel audio, so I can not test the effect myself.
    @Nordfinn I think you have a statement now and could test it. I’ve no TV channels with multichannel audio, so I can not test the...
    Is there a way to set the default audio stream for live TV? The default default, so to speak, for me seems to be English...
    Replies
    3
    Views
    302
    TVE 3,5 as you noticed in my other Thread.
    TVE 3,5 as you noticed in my other Thread.
    Hello Folks, Although the New MediaPortal Version 2.5 looks great so far, it seems that it still has major Bugs? I created a...
    Replies
    2
    Views
    292
    I have recently updated from MP 1.30 to 1.31 on a Win 11 PC slightly different to your software set up but given Win 10 is still supported I doubt there are many major differences regarding the ".NET Runtime Optimization Service". On my setup I am not seeing any significant CPU usuage MP takes around 3% and the TV Service is...
    I have recently updated from MP 1.30 to 1.31 on a Win 11 PC slightly different to your software set up but given Win 10 is still...
    Hi, I have a single seat setup with MP 1.31 on a Win10 machine. Since the last automated Windows update the TV-Service produces a...
    Replies
    7
    Views
    1K
    Top Bottom