LCARS skin? (1 Viewer)

CodeMonkey

Portal Pro
December 8, 2004
360
30
North America
Home Country
United States of America United States of America
OK, I have my flame retardant underware on so flame away if you must :)

But I can't believe MP doesn't have a Star Trek themed skin yet :) I myself am artistically challenged, or I'd probably try one myself :)
 

butcherBoy

Portal Pro
September 7, 2004
100
0
Germany
he he! nice idea! thought about it month ago. but after finishing my first skin for mp i realised that skinning for mp is a hard job. not only because of its really fast development and changes. at the moment i don't have the time to do the job. maybe someone else like this idea, too. i have a nice collection of trek-art for inspiration.

btw. there is a lcars skin for gbpvr out. but i think it can be done better!

http://www.bladerhq.com/pmwiki/pmwiki.php/Plugin/SkinLCARS

the butcher
 

butcherBoy

Portal Pro
September 7, 2004
100
0
Germany
made a rough draft how it could look like. maybe someone can make some nice 3d renderings for the overlay pictures.

lcars_draft.gif


the butcher
 

Inker

Retired Team Member
  • Premium Supporter
  • December 6, 2004
    2,055
    318
    nice

    being a bit of a trekkie myself, Id love to have one of those myself

    If only we had that skin editor yet, huh? :)

    Inker
     

    CodeMonkey

    Portal Pro
    December 8, 2004
    360
    30
    North America
    Home Country
    United States of America United States of America
    Inker said:
    nice

    being a bit of a trekkie myself, Id love to have one of those myself

    If only we had that skin editor yet, huh? :)

    Inker

    I was thinking that too Inker :) Nice butcher :)
     

    Callifo

    Retired Team Member
  • Premium Supporter
  • December 7, 2004
    1,439
    21
    Adelaide, Australia
    Home Country
    Gave this a go, and got mildly far. Sound two problems with the above pic which I was trying to copy.

    1) Cant find a string to supply System Date/Time
    2) Bold and caps are no go (bold is in the latest cvs)

    Someone want to make a new font file for MP as I have no idea how to do that?

    lcars.jpg


    Date is busted as thats as far as I got for now. Also need to find a look for those livetv/shutdown/close buttons. Hover image for settings is real, not a static background pic.

    Edit: May have sorted the buttons (I like them) but they would only be accessable to people using keyboards/remotes. You cant cursor over them....

    lcars1.jpg


    Moving left and right moves between different graphics. All three buttons are on top of each other and when you move back to the menu it goes back to the regular colour. (compare first and second pic)
     

    CodeMonkey

    Portal Pro
    December 8, 2004
    360
    30
    North America
    Home Country
    United States of America United States of America
    I like it :)

    I have a lcars true type font (.ttf). Is that what you need? If so PM me with a email address and I will send it to you.

    The fonts.xml file just references available system fonts. So for the lcars.ttf font I could send you, you would have entries in the fonts.xml file like:

    Code:
    <fonts>
      <font>
        <name>lcars10</name>
        <filename>LCARS</filename>
        <height>10</height>
      </font>
    </fonts>
    I created one for the lcars font, If you would like i can send that with the ttf file and you could use it instead of your existing font file.
     

    Inker

    Retired Team Member
  • Premium Supporter
  • December 6, 2004
    2,055
    318
    well, what do you know,

    I also taped something together real quick just to test an idea. I wont have much time in the near future, but if someone would like to use some of my ideas feel free to go right ahead. BTW for a skin like this I recommand to put alternative .wav files into the skins sound folder.....sounds great :)

    btw http://www.lcars-interface.de/ is a great resource too (they even have fla (flash source files) for download which I guess would help alot in creating all the buttons etc.)
    so anyways, maybe some inspiration (obviously it needs alot of work)

    Home Menu:
    lcars1.GIF


    Video OSD (showing Info gathered from TVTome plugin .... hey, a little ad never hurts, right? :)):
    lcars2.JPG


    Inker
     

    Users who are viewing this thread

    Similar threads

    I've done a few MP1 installs in the past and haven't had a problem, so I didn't expect one today. I just purchased a mini PC with Win11 installed. I downloaded and tried installing Mediaportal 1. I chose single click standard installation with no TV. It started working on things and I wasn't paying terribly close attention, but...
    I've done a few MP1 installs in the past and haven't had a problem, so I didn't expect one today. I just purchased a mini PC with...
    I've done a few MP1 installs in the past and haven't had a problem, so I didn't expect one today. I just purchased a mini PC with...
    Replies
    0
    Views
    258
    You can always use GitHub online But judging by the picture, you are doing well. Direct Push to Master is prohibited, create PR.
    You can always use GitHub online But judging by the picture, you are doing well. Direct Push to Master is prohibited, create PR.
    Hello, Because I was annoyed with closing MP, launch config, modify setting and start MP again, I decided to give MP the ability...
    Replies
    5
    Views
    405
    I removed all sign of MySQL, rebooted, did a clean reinstall. It reinstalled 5.6, But I've still got both the same problem - unable to connect to any of the specified MySQL hosts. And Hostname is still in red. I don't understand - this is a dedicated TV computer. Unless an update did this I don't know why there's a problem in the...
    I removed all sign of MySQL, rebooted, did a clean reinstall. It reinstalled 5.6, But I've still got both the same problem -...
    I've been using MediaPortal for 20 or so years. Last night it recorded perfectly. This arvo it doesn't - will run videos but not...
    Replies
    2
    Views
    562
    I uninstalled MP, made sure no sub folders were left n any programmes folders, changed the computer name, rebooted, installed MP and set logs and rebooted and ran TVServer. Didn't do anything in regard to S Loopback adapter. I've been using NextPvr since the problem became insurmountable. Only reason it's not a good long term...
    I uninstalled MP, made sure no sub folders were left n any programmes folders, changed the computer name, rebooted, installed MP...
    I've been using MediaPortal for 20 or so years. Last night it recorded perfectly. This arvo it doesn't - will run videos but not...
    Replies
    24
    Views
    2K
    Hi, First off: there are some issues with the latest Mediaportal (32bits vs 64bits), so that is one of the issues you're stumbling with. If you take the previous version (1.31) it should work as expected. For IPTV there is also a different option (with different pros and cons): Onlinevideos. I'm using that sometimes for my IPTV as...
    Hi, First off: there are some issues with the latest Mediaportal (32bits vs 64bits), so that is one of the issues you're stumbling...
    Hi I am trying to play a m3u file from my IPTV provider, but when I try to install the TV part of Media Portal v1.3.2 I get an...
    Replies
    1
    Views
    770
    Top Bottom