Youtube is broken... | Page 12

Discussion in 'OnlineVideos' started by Hes, May 5, 2015.

  1. eetaylog

    eetaylog Portal Pro

    Joined:
    March 6, 2007
    Messages:
    874
    Likes Received:
    32
    Gender:
    Male
    Occupation:
    Electronics technician
    Location:
    South London
    Ratings:
    +44 / 2
    Home Country:
    England England
    Show System Specs
    My guess is that you haven't installed URLSplitter. Download it from Extension installer and you should be good to go.

     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Joaquin

    Joaquin Portal Member

    Joined:
    December 28, 2013
    Messages:
    33
    Likes Received:
    10
    Gender:
    Male
    Ratings:
    +20 / 0
    Home Country:
    Spain Spain
    Hello and I hope you are having a good summer :).

    This is just to notify Youtube does not appear in the sites list. This happens in my HTPC and in my “regular” PC I have made a clean installation of Media Portal + Online videos + URL source filters.

    Before posting this message I have disabled any firewalls. I have updated the sites list. Even I have opened the Plugin Config in the Media Portal Extension Manager and deleted all sites but YouTube. Nothing of the above worked: Youtube does not appear as a site when I run MediaPortal. When I use the Organize Sites utility inside MP it appears with a yellow circle and it reports it has been updated in June 2015.

    Please find attached a log.

    Thank you.
     
  4. doskabouter
    • Premium Supporter

    doskabouter Community Plugin Dev

    Joined:
    September 27, 2009
    Messages:
    2,805
    Likes Received:
    757
    Location:
    Nuenen
    Ratings:
    +1,123 / 1
    Home Country:
    Netherlands Netherlands
    Show System Specs
    You have to .NET Framework 4.5.2, then it'll work (I should really put this in a faq somewhere...)
     
  5. Joaquin

    Joaquin Portal Member

    Joined:
    December 28, 2013
    Messages:
    33
    Likes Received:
    10
    Gender:
    Male
    Ratings:
    +20 / 0
    Home Country:
    Spain Spain
    Thank you Doskabouter. Installing .NET Framework 4.5.2 did the job.

    Maybe it would be a good idea adding a small note in the extension installer itself about installing .NET Framework and source filters.
     
  6. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    Sorry for the .net 4.5 requirement - it is due to the new google youtube api using .net 4.5. I have embedded some dlls into my siteutil dll via build task that include the types for the .net 4.0 framework and it seems I missed at least one.

    Here's a new dll (simply overwrite the old in in MP install dir/Plugins/Windows/OnlineVideos/).

    If someone with the same problem (logs read: Could not load type 'System.IProgress`1' from assembly 'mscorlib, Version=4.0.0.0) can test this on a PC without .net 4.5.x installed, I'd be happy to hear the results.
     

    Attached Files:

    • Like Like x 2
  7. Joaquin

    Joaquin Portal Member

    Joined:
    December 28, 2013
    Messages:
    33
    Likes Received:
    10
    Gender:
    Male
    Ratings:
    +20 / 0
    Home Country:
    Spain Spain
    Thank you! At least you keep updating the plugin, not like many manufacturers like LG. I bought them a 600 € TV about 5 years ago with built-in Netcast featuring a YouTube app that has became useless since the latest update from YouTube's API. LG does not update it anymore. Smart TVs are a waste of money. They become outdated in a short time.
     
    • Agree Agree x 1
  8. Rick164
    • Super User

    Rick164 Super User

    Joined:
    January 7, 2006
    Messages:
    1,335
    Likes Received:
    918
    Ratings:
    +1,359 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
  9. edsche
    • Premium Supporter

    edsche Community Plugin Dev

    Joined:
    January 7, 2007
    Messages:
    606
    Likes Received:
    300
    Location:
    Ulm
    Ratings:
    +338 / 0
    Home Country:
    Germany Germany
    Hi offbyone,

    since some days YouTube doesnt work anymore here. I've tried already your dll from #115 but this dll doesn't also work.

    I'm on Win 10 x64 with MP 1.12.

    Here is the log. Thanks in advance :)
     
  10. xfx

    xfx Portal Pro

    Joined:
    February 1, 2011
    Messages:
    85
    Likes Received:
    4
    Gender:
    Male
    Occupation:
    Software Developer
    Location:
    Santiago, Dominican Republic
    Ratings:
    +9 / 0
    Home Country:
    Spain Spain
    Show System Specs
    If you are referring to the "MediaPortal IPTV filter and url source splitter", then yes - it's installed.
    Otherwise, I can't find any extension named "URLSplitter".
     
  11. offbyone
    • Team MediaPortal

    offbyone Development Group

    Joined:
    April 26, 2008
    Messages:
    3,981
    Likes Received:
    2,704
    Gender:
    Male
    Location:
    Stuttgart
    Ratings:
    +3,303 / 3
    Home Country:
    Germany Germany
    Show System Specs
    @edsche :
    Can you try Youtube with the setting "Enable Login" to false? Your log shows an error that comes from the youtube query api (one that is not helping: Mindestens ein Fehler ist aufgetreten). If that works then maybe check your credentials.
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!