Amazon Prime Germany? (2 Viewers)

morpheus_xx

Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,703
    7,101
    Germany Germany
    Country flag
    Thanks for confirming that at least the browser mode works :)
    IIRC offbyone wrote some time before that he prepared the browser player to be more independent from MP1. So we have a clear task now, to bring it into MP2.
     

    Ministerk

    Super User
  • Team MediaPortal
  • Super User
  • November 28, 2007
    970
    826
    Uppsala
    Sweden Sweden
    Country flag
    [...] So we have a clear task now, to bring it into MP2[...]
    OT: That would be great! Thats one of two things missing for me when it comes to using MP2 as ordinary HTPC now when external subs are supported. The second thing thats missing is Rockstar/Spotify.
     

    Der_Bub

    MP Donator
  • Premium Supporter
  • June 17, 2008
    830
    60
    Cologne
    Germany Germany
    Country flag
    Actually I'm not able to watch anything: After selecting a Film/Series just a short white Screen/Flash and nothing happens :(
    (silverlight & Browser in settings of MP & Amazon)

    Via Browser it was possible to watch.

    Can somebody confirm this? Or it's a "local" problem of my system (will post logs in the evening...)
     

    steutelings

    Portal Member
    May 20, 2012
    8
    1
    51
    Germany Germany
    I have the same problem. A short white Screen/Flash and nothing happens. Sometime an errormesage for

    OnlineVideos.WebAutomation.BrowserHost.exe

    Eventlog:
    Name der fehlerhaften Anwendung: OnlineVideos.WebAutomation.BrowserHost.exe, Version: 2.1.0.0, Zeitstempel: 0x560688b5
    Name des fehlerhaften Moduls: clr.dll, Version: 4.6.1063.1, Zeitstempel: 0x5653653c
    Ausnahmecode: 0xc0000409
    Fehleroffset: 0x0001da97
    Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Team MediaPortal\MediaPortal\plugins\windows\OnlineVideos\OnlineVideos.WebAutomation.BrowserHost.exe
    Pfad des fehlerhaften Moduls: C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr.dll

    OS Win10
     

    steutelings

    Portal Member
    May 20, 2012
    8
    1
    51
    Germany Germany
    Thx for Reply, but it's not working. The same prob existing on my Win7 so i installed Win10. Playing in Edge, Iexplore no probs.
    KB3132372 isn't installed.
    Exception: net.pipe://localhost/WebBrowserPlayerCallbackService : Der Pipeendpunkt "net.pipe://localhost/WebBrowserPlayerCallbackService" wurde nicht auf dem lokalen Computer gefunden.
     

    Freak*96

    Portal Pro
    January 24, 2009
    74
    9
    Germany Germany
    Country flag
    Same for me. Amazon Prime Video works in every Browser but in OV I only get a short loading screen and then it switch back to menu. On another HTPC I only get sound but black screen. Both PCs running win 8.1 and i already tryout uninstalling KB3132372...
     

    morpheus_xx

    Lead Dev MP2
  • Team MediaPortal
  • March 24, 2007
    11,703
    7,101
    Germany Germany
    Country flag
    @JSurf
    I had also issues from time to time. Login randomly failed, so the content of categories could not be loaded. I have debugged it and found out, that you can be redirected to two different login pages. The contained forms and input elements are using different names.

    The issue happens randomly, there is no guarantee that the same page is used for next retry. So I modified the login to check both forms. But I could not verify the result yet, because when I retried the "normal" form was presented again.

    For all who might have similar issues, please try the attached assembly! For usage inside MP2 it needs to be placed into folder: C:\ProgramData\Team MediaPortal\MP2-Client\OnlineVideos\SiteUtils. For MP1 I don't know the correct location.
     

    Attachments

    anderschw

    Portal Member
    February 27, 2008
    16
    1
    Since a view days I have the same Problem. Screen blanks goes black and after the waiting animation the watchlist will be shown.
    With the KB3132372 "Security Update for Flash Player on Windows 10" I got a Exception.
    The history with the amazone prime is very long.
    In december after update to WIN10 the amazon prime site has no problem.
    In January after KB3132372 the amazon site takes an exception.
    After deinstalling and preventing for new installation the amazon prime site is possible without any problems.
    Since plus or minus on week I got no amazon prime (two different WIN10 installations).

    Tried:
    - Deinstall all new Fixes of WIN10
    - Reinstall Silverlight 64xBit
    - Reinstall OnlineVideos
    - Chance the configuration of onlineVideos (because somtime this kind of problems where solved with new paramaters)
    - Change Default Browser from IE11, Edge, Mozilla

    All these steps doesn't lead to any change.
    When i look to the log I didn't have any problems. The last log-entry is the call (get-url) for the stream.
    If I copy this entry into any of my installed browsers the stream starts.

    But, after this thread I think the rollback to WIN7 didn't bring the solution (because some of the other users have same problems in WIN7)

    Is there any possibility to configure the browser witch is used by OnlineVideos?
    Because when I use IE11 or Edge for streaming the browser uses HTML5 not the silverlight plugin.

    Are there any configurations (WIN 7/8/10 32/64 - Browser - Silverlight 32/64) able to use Amazon Prime?

    Thanks in advance
     

    Freak*96

    Portal Pro
    January 24, 2009
    74
    9
    Germany Germany
    Country flag
    Is there any solution for the silverlight / html5 problem.

    It's the same for me, got only sound and black screen in MP and for me it looks like mp / IE doesn't use silverlight.
    If I start IE in admin mode it uses silverlight, without admin mode it uses HTML5....

    Any ideas?

    Gesendet von meinem SM-G935F mit Tapatalk
     

    Users who are viewing this thread

    Similar threads

    Top Bottom